A Few Pop-Up Gallery Issues and Findings


I don’t have a URL you can look at as the site is in development and hasn’t been published to the production server. I do development in a sandbox Apache instance on my Synology NAS. However, the issues I have here appear to be independent of the project specifics

Issues With Safari 14.0.3 under Big Sur 11.2.3

For some reason the following items do NOT work on this version of Safari:

The Right & Left Arrows do not go next or previous. The arrows themselves DO highlight when hovered over, but clicking them does not work.

The Close X button has the same issue. Highlights, but does not do anything when clicked.

The Zoom In / Out / Fullscreen / Thumbnail Collapse DO work however.

I am not seeing this issue on iPad OS, iOS or Android with a Google Chrome Client, nor on Big Sur with Google Chrome either. Seems to just be the Big Sur Safari.

Issue Reading Directory in Gallery Sub folder as a file

This is related to the Sandbox Apache being on a Synology NAS, however it could crop up elsewhere. The Synology creates index directories (similar to the finder’s hidden directories for each folder) for the same purpose, to store extended attributes. This is necessary for Synologies Photo hosting, allowing Time Machine shares to work and to allow Mac OS clients to properly see and store Finder folder attributes. The Synology OS creates these directories (in each directory that is indexed and they are named @eaDir. This has not been an issue up until I added Pop-Up galleries to pages and used the batch import feature.

For some reason Pop-Up Gallery is reading the @eaDir directory name and is thinking it’s a photo as the first image in every gallery is shown as a generic file icon and displays as black. Obviously not an issue for when published to the production server, but it took a while to locate and verify that this is what’s going on. If I SSH into the NAS and navigate to the web directory in question and RM -R the @eaDir in the batch import subfolder, the issue goes away, but then instantly resurfaces if I republish or make make any changes to the actual photo contents of the directory in question, as the Synology re-indexes on any write op to a directory. There’s a brute force way of disabling it, but it’d break the ability to use time machine and a lot of other functionality in the process so that’s off the table.

Further on re-publishing the page AFTER deleting the @eaDir, RW is writing .ds_store files to the web directory (where previously Synology was putting those in the @eaDir directory) which is causing the same thing, generic image placeholder icon and a black image.

I’m guessing Pop-Up Gallery isn’t expecting anything but photo files and the thumbnails subdirectory in batch mode, but probably should be.

Feature Comment

AFAICT, Pop-Up Gallery’s display order in batch mode solely based on file name. I get that, it’s the obvious way to order them, however for my usage, these galleries are various pictures of products once installed in the field. Due to all the batch processing and subsequent file naming to get the square thumbnails and whatnot they end up presenting a really boring slide show as you see all the pictures of the product in one color, then the next color, first the portrait orientations then the landscapes. It’d be nice to have some kind of randomize function just to mix up the order, and would save a LOT of work to manually rename, then regenerate thumbnails for several hundred product photos. Is this something that’s doable or is there some 3rd party utility out there that could accomplish this without a mess of work?



Good morning @LewnWorx

I’ve just loaded up the Pop-Up Gallery stack in Safari on Big Sur and all seems to be working A-OKAY here. I’ve recorded a video showing the above items working as expected. My installation of Safari doesn’t have any extensions or plugins running aside from 1Password. If you’re running any Safari extensions or plugins try disabling them, restarting Safari, and see if things work for you. Additionally try the examples on the Foundry Documentation page for the Pop-Up Gallery and see if they work for you.

Here’s the screen recording I mentioned above: https://d.pr/v/RISAnJ

As you mentioned the stack is looking for images only. The import folder should contain only images and nothing else. I believe this has been touched on here on the forum previously, but I could be mistaken.

I’m not sure this is something I want to add to the stack at this time. That said I’ll note it as a request.

No extensions, in fact a from scratch fresh install of Big Sur 3 weeks ago, didn’t use migration assistant, so literally clean slate from ground zero.

Oddly the zoom / play pause / and other buttons all work as expected, just the two arrows and close that do not. Will just a generic foundry page. As mentioned only affects those 3 items on safari Big Sur only. Chrome and Mozilla are fine, as is safari on iOS. Will let you know what the generic page test does.

Fair nuff. It’s just an annoyance during development, but based on your not having reported issues on deployed sites, I’ll take that as a safe bet that 3rd party hosted Apache sites aren’t putting files in there.

And on the last bit, I just did a manual workaround. I put the actual and thumbnail images in a single directory and just prepended the file names with 00-01 etc to force the display order. IF i had more time I’d write a utility to do that for me, but have other fish to fry at the moment.

Thanks. Will let ya know what I find on the first bit.

Well Good news. Found the problem with the Arrows / Close Button.

The page had previously been published with RWThemes Animask on it, and I added pop-up gallery later.

So first I set Animask to not publish to not publish and tested that and popup gallery arrows and close “X” worked, then when I re-enabled Animask and republished it, it worked as well. Not sure how or why that fixed it but it did.