Accordion Problems

Looking for some advice - I have an accordion on my site that isn’t functioning properly.

The first three times are perfect, no issues with the custom formatting, but the 4th accordion section won’t accept the custom formatting.

Here is a link to the site - (its just a simple page with commonly clicked on links)

This is what it looks like in rapid weaver and even in the local safari preview:

(I tried to post what it looks like on the published site but the forum won’t allow me to add more than on image)

Hi there @jarroddale – Any chance you can provide a copy of your project file? It would be helpful to have it in hand to look at to see how things are setup.

No problem, how would you like me to get it to you? I will say I am on rapid weaver 7 and foundry 1, but my lack of upgrading shouldn’t break old functionality should it?

You can send me a download link to a ZIP file containing your project file at adam at elixirgraphics dot com

If the file is more than 4mb or so, please send it through something like Dropbox, or a similar service, otherwise it will get bounced back.

Upgrading or not has nothing to do with it at all.

Will do, its 35mb, I think b/c of uploaded resources.

The other thing I am interested in is the accordion function, I can start with certain tabs open, but they auto-close when I open one of the closed tabs. Is there a way to have them stay open? (not a big deal though)

Sending file…

No, that is not an option. That is what an accordion in web design is most often designed to do. This is true of the Accordion stack in Foundry.

I just did a test publish, without changing anything, and it seems to be working fine here:

Can you do me a favor? Quit and restart RapidWeaver and then do a “Republish All Files” from RapidWeaver. Once you’ve done that clear your browser cache and reload the page on your server.

Following up - re-publishing everything fixed the problem. Thank you for your awesome service. I guess it might be time to upgrade to Foundry V2.


Not a problem. Glad to help out. A good Republish All Files can most times knock out some little thing that may have gotten out of whack. Happy you got it sorted out.

Quitting RapidWeaver solved the same problem for me as well… thank you both!