Alloy and Pretty URL canonical indexing

Yeah, option one is without a doubt a no-go. It would be the best one and make things the easiest all round, but would also cause serious problems that would generate a tsunami of support for me.

I’ve thought on it a lot this morning and I can’t think of another alternative, besides the extra checkbox, that would work within the constraints I’m under right now. I’ll keep thinking on it though as I forge ahead on my current stuff.

1 Like

Could this be helped by adding all blog entries the the sitemap?

I am not a sitemap expert so I can’t answer your question directly. That said – Alloy cannot modify the sitemap file. Well, to be more precise, I wouldn’t modify the sitemap file as then Alloy becomes the one responsible for creating and maintaining your sitemap file, and that is not what Alloy is for.


you can use the Alloy rss.xml file :wink:

Thank you Pegasus. I’m looking for a work around. I’ll add the RSS file.

if you use this for the googlesearch console … you can submit both … the sitemap.xml and the rss.xml

Done, waiting to see what happens. I had the sitemap already loaded, it didn’t include blog pages, I added two to see if it would index them overnight, it didn’t.

I added the RSS xml and it sees all the pages, will see if it actually indexes them tomorrow.

Thank you again for your help.

are you using “pretty url”? if so… i would not advise it. without - ALLOY runs perfect.

I have almost 10 blogs running with Alloy - all are indexed and also have a google ranking.

I do have pretty URLs turned on, wasn’t aware this typical use case didn’t work.

I have 25 post, if I turn off pretty URLs what’s the impact? Do I have to delete and reload the post?

I’ll confirm the other settings. As of now, with the RSS.xml, it sees the pages but hasn’t indexed them. I’ve manually requested some pages, one of them was indexed.

If you turn off pretty urls you can always write a redirect for each url in your htaccess file.

Just disabled the “Generate Social Tags” option. Not sure how to disable the canonical URL.

that’s right. and I can really recommend it …

it is already working - but it can brings some nasty problems… take look in this thread

you can just turn off the pretty url … but make sure you also delete the “pretty url” entry in in your htaccess file.

give google one week … then your pages should be in index

Thank you! I’ll report back next week.

if you don’t use a canonical URL for your BLOG everything is fine … the correct canonical URL then sets ALLOY for you