Alloy Editor 404 error upon login

I successfully set up my blog page using Alloy a few days ago. I was able to log into the Editor and create a few posts. I’m redoing a non-RW site in RW and have several dozen blog posts to migrate over, so I’ve been using a MAMP Pro server to make the edits locally before I’m ready to go live. Besides oddly not being able to upload any images (maybe an issue with MAMP or an early sign that something was terribly wrong in RW?), everything else seemed to be working fine, but today I came back to it and after the Editor login is just a 404 Not Found page. Here’s a screen shot:
Screen Shot 2021-11-04 at 6.49.43 PM

Things I’ve tried with no luck:

  • refreshing the browser, clearing the cache, and trying a different browser
  • re-uploading the site files countless times
  • restarting RW
  • restarting the computer
  • restarting MAMP
  • deleting all the previously published pages and publishing from scratch
  • duplicating the editor page
  • creating a new editor page including doing the hashed pass password setup all over again
  • deleting the copy page and doing the hashed pass password setup again on the original editor page
  • uploading to the actual web hosting (this didn’t even let me get to the Editor page, just a white page with a bunch of random stuff, though the rest of the site looked and worked fine).

Unfortunately, the blog posts I had added thus far are now gone. I didn’t edit the blog page and I never deleted the original editor page, so I’m assuming those posts were lost when I deleted everything from the local folder and re-published?

This is all very disconcerting, and honestly makes me pretty concerned about using Alloy going forward. Had I uploaded the several dozen blog posts rather than just a few and had this happen I would be really losing it right now! I suppose that since those blog posts are gone anyway I might as well delete everything related to the blog and really start from scratch to see what happens, but again, I’m getting pretty nervous about putting a lot of effort into something that may break again at the end of a lot more work.

Any ideas? It seemed like it was going to be great…

If it helps to know, I’m using RW 8 and Alloy 3.2.0 on a MacBook Pro running High Sierra 10.13.6, MAMP was running PHP 7.2.34, actual web hosting was GoDaddy (hopefully not for much longer though!), and I tried both Firefox and Chrome.

Thank you!

The 404 error sounds like a problem with your MAMP setup. Perhaps the MAMP server was off when you tried visiting the page. That said I did not design Alloy for use with MAMP and I don’t personally offer support for that setup. Others have used Alloy fine with MAMP though.

As for your missing posts — you likely deleted your posts folder. This and the images, droplets and embeds do not get uploaded by RapidWeaver. They’re created by Alloy from the Editor on the server. If you delete them you’re deleting your content. That content is not stored in RW, but in those folders on the server. When RW republishes it does not touch these folders. They would have only been deleted because you manually did so. This is likely when you lost them:

You probably deleted everything including your Alloy generated content.

Lastly I would dissuade you from using GoDaddy. They’re not a good host. Not in the least. And their PHP installations are notoriously fraught with problems. Additionally their support is abysmal as well.

Hi Laurel,

when I set up my first Alloy blog I couldn’t upload images either. After thoroughly reading Adams documentation I found out I still named my page folders something like “/blog”. An old habit. Once I abandoned the “/” in the name everything worked fine.

Just an idea.


Thanks guys. It now seems it’s likely not Alloy and something must be messed up with my MAMP, GoDaddy (what else is new there, yes, I’ll be switching to something else soon!), or just my computer. When I tried uploading some changes to another RW site I’ve created, the upload was successful but the changes wouldn’t show up on my computer no matter what browser I used, or how many times I shift-refreshed, cleared the cache etc., but they’re all there when I visit the site on another device. Quite a few other people’s websites since this issue started yesterday won’t load either, or won’t load one minute, with various “can’t find the file” type messages showing up instead, but will the next. I can’t imagine the general internet is breaking, so I’m assuming this is all related to my issue with not being able to fully log into the Alloy editor… It’s probably not an Alloy issue anymore, but if anyone has an idea about what I should try next let me know :frowning: