Alloy Editor Page Validation Error

Hello- I’m running into an error with my editor page on a blog. I can log in to my editor page, but when I click on any of the editor features (such as add new post, or edit post…) I am brought back to the login page.

I followed the Alloy instructional videos on the topic while making the pages. When I first got the error, I tried resetting the password, then I tried rebuilding the page, but neither fixed the issue. I’ve also tried deleting my page from the server and re-publishing it.

I saw one post from last year about this, but I did not find a solution. Has anyone else run into this and fixed it?

Thank you!

Additional info- I just tested the same process using another website and domain had had the same result.

Good day @emilytradersabacus

First a couple of questions:

  • What version of PHP are you running?
  • Have you nested the Editor page in another page? If you’re unsure, share a screenshot of your page list in RapidWeaver that shows the Editor page.

Beyond that, at a minimum I’m going to need a link to your Editor page if I’m going to be able to help out. I also would like to get a ZIP file containing your project file. This would be the file you open in RapidWeaver when editing your site. You can email that ZIP file to me at adam at elixirgraphics dot com

If the ZIP file is over 4mb or so, you’ll want to send it using Dropbox, WeTransfer or a similar service.

Thanks for your response-
• I’m running PHP 7.3.11
• The pages are not nested

Have you found and fixed this problem before?

I can’t know if it is something I’ve dealt with it before until I troubleshoot it. Without the requested items I cannot begin to troubleshoot it.

Just got your project file. Looks like you’ve not supplied the required website URL in the publishing settings.

Alloy needs this to be able to form URLs properly. Just to be clear, the greyed out URL there is just placeholder text that RW is recommending. That is not an actual URL. You still need to type the correct URL if I am not mistaken.

Add the URL to your site and then do a Republish All Files from within RapidWeaver.

After doing so, revisit the site and login to the Editor and let me know if that solves your problem. If not, I’ll take a deeper look when I’m back in the office in the morning.

Hi Adam,

Thank you for pointing that out, I’m surprised that mistake was not causing more problems. Unfortunately, after fixing that and republishing I’m still having the same problem with my editor page.

Can you email me a copy of your PHP error log file?

Addendum: I also sent you an email with a link to where I’ve published your project file, along with login credentials, if you’d like to try it out. Everything appears to be working fine over here with Alloy itself. If you can provide that log file though I can better troubleshoot.

Thanks, Adam. I tried out the link you sent and can confirm it is working properly. I did find out that my server was running php 5.5, not 7.3 like I thought. I updated it and fully republished the site- still getting the error.

I’ll email you the information you’ve asked for.

Did you give the server a bit of time to update to PHP v7.x.x before testing? It usually takes the host a little while to switch over.

Also, just out of curiosity, who is your host?

Host is Fatcow- I gave it a few minutes, but it’s been an hour or more now, I’ll try again and let you know

I tried again with no luck

Got information back from @emilytradersabacusvia email where we were troubleshooting back and forth. Looks like it has been resolved by changes made by @emilytradersabacus’ host. YAY!

Yes! For anyone viewing this in the future; My server was running an older version of PHP, I needed to update that to the most current. Also, be sure that your server has session data saving on by default.

1 Like