Alloy embeds; file doesn't exist error

I’m having a problem with Alloy embeds (“the file doesn’t exist” error). I’ve read other posts relating to this problem and tried multiple fixes. No luck yet. Here’s my configuration:

I’m running RW Classic 9.1.1 and Stacks 5
I’m hosting my website on Dreamhost, which installs cURL in its systems
My website host is running PHP 7.4
I have validated that the markdown file created for the embed exists on the server. In fact, I can see it with FileZilla AND if I enter the URL for the md file, it shows up in my browser

I have republished the site multiple times; no luck
I have cleared the cache on Safari multiple times; no luck
I have accessed my site via Chrome; no luck

So I know the file is being published by the Alloy Editor and is where it should be (in the embeds folder) and I know the URL is correct.


Check that your Site URLs for your General and Publishing settings are correct. This includes making sure that the appropriate prefix is being used (http:// or https://) depending on your whether you are using an SSL certificate. If you have to change these settings and republish you’ll also need to update the URL within your Embed’s settings in RW.

If you think everything is configured correctly then you’ll need to provide us the following in order to assist you:

  • A copy of your project file. Create a ZIP file containing your project file. This is the file you open in RapidWeaver to edit your site. After creating the ZIP file, upload it using a service like Dropbox, WeTransfer, Droplr, or a similar service to create download link for us. Paste that download link in your reply.
  • URL to the page with the problem on your site.

The Site URLs are all the same and correct. The zipped project file is on its way to you. Thanks for your help.

I suspect you have set your server settings to add the www to the address in your Dreamhost settings, but your URLs within your project file do not reflect this:

As an experiment, go into your embed and add the www. into the URL. You can then preview the page and see that the embed loads.

As an aside – you’re placing content above your Control Center on your page. All content should be placed below the Control Center.

You da’ man! I checked my Dreamhost and settings, changed them so that they didn’t insert a www as a prefix, published a new embed, and voila! Works perfectly! Thanks for the prompt support!

Sure thing! Glad it was an easy one. :+1:

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.