Alloy - no longer working

Hi Alloy was working and set up but then I updated to 3 and redid the files now after loggin in I get

Not Found
The requested URL was not found on this server.
with the path /files/stacks_in_24_login.php

I’ve cleared the all the files off the server and republished but sill the same, can you help.


Hi @pat – When you republished did you do a Republish All Files?

Also, did you quit and restart RW after installing your update to Alloy v3?

If you answered yes to both of those, I’ll need some information:

  • What version of RapidWeaver are you using?
  • What version of Stacks are you using?
  • Have you updated to Alloy v3.1.0 yet via the Stacks updater?

Rapidweaver 8.5.1 (had issues with later version so went back to the one that worked)
Latest version of Stacks
Alloy v3.1.0

Hi @pat – It is unclear to me since you didn’t respond to my questions… did you do these steps?


Did that still not working

Please send me a ZIP file containing your project file please. Use WeTransfer or a similar service to make a download link and send that link to: adam at elixirgraphics dot com

Also you said you’re on the latest Stacks version but that is relative unfortunately depending on if you’re using v3 or v4. Can you please let me know specifically which version you’re using? Is it v4.2.2? Something else? A beta? Etc.

Hi Adam,

Stacks 4.2.2 and sent project file via WeTransfer.

You’ve put your Editor in the main root folder of the site. Alloy does not allow this.

You must put Alloy’s Editor into its own folder. This is shown in the Quick Start video in the Alloy documentation.

You should be naming your pages index.php or index.html depending on whether it is a php-base page or not. You’ve named yours editor.php and put it in the root folder. This is a no-no and will not work properly. This goes for all of your pages. They should each get a folder, for example contact for the Contact Us page and not just a slash. Using a slash for the folder name dumps everything into the root folder.

Hi Alan,
Changed that now working. I have found sometimes the Topper Image will not upload is there a size of file best suited.
Thanks again for you very quick help.

Do you mean dimensions-wise or file size itself?

If you mean the latter, then yes, there is a limit. It is 2mb if memory serves. That is far bigger than your topper image file should be anyway. You will want to make sure you’re sizing and cropping your images, as well as setting the proper DPI and optimizing the image before uploading it.