Alloy not allowing blog text

Hello all,

I just got Alloy installed (server is running php 7.3, but I also tested 7.2) and everything seems to work fine until I want to type into the main blog entry box. I’m allowed to change the title and decorative label but nothing happens when I try to type into the main box. Also, the image selector brings up the window to choose an image but does not actually load it. Adding and deleting posts works no problem but I can’t even edit the contents of the example post. No errors are shown, just nothing happens. These are the components of the php installation. Screen Shot 2021-08-30 at 11.49.17 PM|679x500

Hi Margaret,
if you followed the setup of Alloy as described in the documentation, it should work just fine. Initially I had problems with uploading images. Seemed I made a mistake in naming the folders (in general settings) “/blog” instead of “blog” (old habbit).

Screen Shot 2021-08-31 at 08.41.29

also it can have something to do with with your general publishing setup. You need exact and secure URL’s (https://…). These should be exactly the same in ‘General’ and in ‘Publishing’.

Screen Shot 2021-08-31 at 08.47.27

Check these and try again?



Thanks Hans for the quick reply!

I’ve double checked that both folder names and URLs are exactly as you show in your screenshots. The problem persists that it won’t let me type anything (or add any content) into the main content box nor upload a topper image.


Maybe a stupid idea of mine, but you do work on the Foundry theme and environment?

I’m just guessing since you don’t give a lot of information (RW version, Foundry, …)


Good morning @arsl

Sorry to hear you’re having trouble.

Before I dive into what I need to troubleshoot your problem I’d like to recap what you’ve tried in an effort to fix this.

Above @Panans recommended recreating what is seen in the tutorial video(s). When you did that did you build a new, basic page that exactly replicates what is seen in the video, leaving out anything superfluous for testing? If not, please give that a try. It may be that you’ve got something on your original page that is causing a conflict.

If you did try that, or have now tried that and still have the problem, please provide me the following things in order for me to troubleshoot your problem:

  • I’ll need to know what specific versions of the following you’re using: RapidWeaver, Stacks, Foundry, OS X.
  • Send me a ZIP file containing your project file – this is the file you open in Rapidweaver to edit your site. Additionally if you’re using any non-Elixir stacks on the trouble page I will need those included as well to be able to test the problem.
  • It would also be very helpful to have a link to your Editor page along with a login for it so I can test what you’re seeing directly.
  • If you have the ability a screen recording of the problem would also be helpful as it will allow me to see what you’re doing in action.

You can send the above ZIP file to me via WeTransfer or a similar service. After making a download link via WeTransfer send all of the above to adam at elixirgraphics dot com

Thank you Hans and Adam for the quick responses! Turns out it was a very silly error. On the blank initial stack page as shown in the video I forgot to add the Foundry stack. I had added it to the Editor and Blog pages, but not that initial blank page. I’m using Foundry and Alloy 3.1.6. After adding the main foundry stack to that blank initial page and republishing it works well.


Good to hear. Glad you got it sorted.