Alloy Paragraph Font Size - Edit: Solved it was a silly error on my part

Hiya, I’ve now moved on from learning Foundry 2, now really eager for Friday’s Foundry 3. So I have been getting to grips with Alloy. My goodness it is good. Gone through every setting, recreating a customers blog, then breaking the system on purpose, deleting everything off server, republishing etc and restoring so I’m familiar if something ever goes wrong with hosting or somebody moving server. Loving it.

Gone through all settings but one thing is really foxing me, it is the paragrah font size in blog posts.

The Foundry Control Centre is using a Typeface and has custom Paragrah sizes in this case 16, 18, 24 in the Control Centre paragraph text size. This works great with the partial used for Control Centre on standard Foundry produced static pages. The same Control Centre partial is used on the blog page but paragraph in blog pages seems to only want to use the Base Font sizing of 16. The result is smaller and the same for all screen sizes, which makes sense if it is using the Base Font sizing. To check that it is referencing the Base Font I temporarily changed the Base Font size and colour to check, then put the settings back to default.

Therefore I get paragraph font sizes being the custom defined size in Foundry pages and smaller and the same for all screen sizes in a blog post, screenshot attached. Foundry static page paragrah in orange in top window, blog post on white background in bottom window.

I then wondered if it is because the markup has to be specifically encapsulated in paragraph markup, so I tried that but no different, however without doing that I also noticed in the source code of the published page plain text is being encapsulated in
paragraph markup anyway, see screenshot.

I just wanted to check if it is the case that the Base Font is the size that blog posts uses so use that accordingly or is there something I’m missing or doing wrong to prevent blog posts from using the Control Centre custom paragraph settings?

All other custom font sizes in Control Centre for Headings is working as expected.



As is the case after chasing my tail for some time and deciding to post, I then find my silly error. Custom Font size needs to be set in Alloy. Screenshot attached.

Screenshot 2023-02-01 at 17.00.26

Hope this helps somebody else starting out with Alloy if they get the same.

Started to reply to this post and then got dragged away to attend to a contractor doing some home repairs. Glad you got it sorted out!

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.