Alloy PHP isuues


I went to my Rapdidweaver blog Editor and Post pages today and found I suddenly had a slew of errors on the page along the lines of these:

Warning: Undefined variable $currentPage in /home/aabhwuec/public_html/editor/index.php on line 223

Warning: Undefined array key “small-label” in /home/aabhwuec/public_html/editor/index.php on line 328

Warning: Undefined array key “summary” in /home/aabhwuec/public_html/editor/index.php on line 333

There were many more. I temporarily “solved” that problem by putting this: <?php error_reporting(0); ?> in the head of both pages.

Once I was finally able to try creating a new post, I discovered that although the selected JPG was uploading to the correct folder on the server, it was not being displayed in the editor page nor in the post. Seemed likely to also be PHP-related, but I notice that on the post with missing image there is no <div class="topper-image-wrapper"> under “summary-topper-wrapper.” So the topper image code isn’t being generated?

Running PHP 8.0 on a Chillidog server. iMac Ventura (13.2.1) RW and Alloy stack are up to date.

Any thoughts?

Thanks for your help — David

Hi, these warnings are just warnings and you did the correct thing to disable the output of those. But these are no bugs or such.

For the jpeg: please check if the file name does not include any special characters. For a test use a simple name like picture.jpg
and make sure it is not a png or such where just the extension has been renamed.

Thank you.


Spaces are treated as special characters, too. Make sure the file name is ‘web safe’.

Thanks, but I already did all of the blindingly obvious tests, including trying to repost a photo already used in a previous post and working. Since so much has been changing with Stacks and plug-in updates recently, and since nothing on the host servers has changed, I though the sudden appearance of these issues after more than a year of using Alloy might be related to software changes. If the answer is simply that it just doesn’t work anymore, it’s no big deal; I can find a way to work around the lack of a blogging option.

Thanks again for your feedback, David

My setup is identical to yours, and is working perfectly, also on Chillidog.

Nothing has changed in Alloy in quite a long while. I suspect something else is likely your problem. If you want to share files with us we can attempt to help. But without them it is just shooting in the dark.

We’d need the following to help out:

  • A copy of your site files from your server. Download your site file via FTP and add them to a ZIP file.
  • Your PHP error log file.
  • Your RapidWeaver project file. This is the file you open in RW to edit your site

Put this all in a ZIP file and share it with us via a sharing service like Dropbox, WeTransfer, etc. You can then share the download link with us here.

You can put them all in a ZIP file.

If you can think of anything you’ve changed recently like PHP versions, etc that would be helpful too.


Thanks for taking a look. You can download the ZIP folder at:

The only change I have made recently is updating Alloy to version 3.3.2 on March 30. The sudden flood of errors and the lack of image topper responsively was noted the first time I logged into Editor after uploading a few site edits. Still running PHP 8.0 on server.

If you have any problems or require more info, let me know.

Thanks, David

Thanks @dmsmith — I’m currently on the road traveling but when I can sit down in front of my Mac next, likely tonight or tomorrow, I’ll take a look if someone else doesn’t beat me to it.

You can turn this off in your host’s PHP settings, which I would recommend as these are all notices, and not errors. Nothing to worry about here. You’re just seeing the notices because you have these messages set to display on the page in your PHP settings.

I took your project file and published it to my server as well as uploaded your posts and all seems to be working A-OKAY here. You can see the blog (here: The Blog) and the editor (here: editor | Benders Novels). You can login and edit the posts and upload new images and see them reflected in the blog and editor. I suspect something on your server isn’t happy with Alloy’s uploader. I’ve not had much luck with Chilling myself. I know people rave about them, so I guess YMMV. That is the only difference between my upload and yours though, otherwise it is the same.

I can do some more tests when I return on a different server as well where I have access to more resources.

Thanks for checking into it. I tried to send you an email yesterday, but it bounce, probably because I tried to reply via a different mail server. (?) I just saw the failure notice. Anyway, I updated to PHP 8.1, and that seemed to fix both issues. Fingers crossed, but I seem to be back on track

Thanks again, David