Blog posts will not save or draft

I have added everything correctly but my blog posts will not save when using the editor. I have tried with safari and google chrome to no avail.

Make sure you follow the video tutorial.` Retrace your steps to make sure.

Hi there @derkaramma

If you’ve not gone through the Quickstart tutorial I would highly suggest it. You might want to replicate the setup you see in the tutorial exactly as a test to make sure you’ve set everything up just right.

If you’ve already done this, and are sure you replicated things exactly, can you please provide some additional details for us? A screen recording of the process of adding a post and trying to save it would be helpful. It would also be very helpful to know the following information, in addition to the screen recording:

  • What version of PHP are you using on your server? PHP v7 is recommended.
  • Have you made sure that your Editor page is a top level page as shown in the tutorial video in the Quickstart section?
  • Is your site URL correctly configured in the General and Publishing sections of RapidWeaver for your project file?
  • When you say the Editor is not saving your posts – do you mean they’ve not been saved on the server when you look using your FTP software, or that they’re not appearing in the Editor Posts List view, or both?
  • Please provide me with a copy of your project file – this is the file you open and edit in RapidWeaver when editing your site. Compress it as a ZIP file then use a service like WeTransfer to create a download link for me. You can post that link here with your responses to all of the above questions.

Any other details you can offer will help me to troubleshoot your problem would be highly appreciated.

  1. PHP 7.3.29
  2. Yes, it’s its own page that’s separate and hidden from navigation
  3. Yes, all of my other changes take effect(I’ve even tried restarting my server)
  4. They are not saving anywhere, the default post doesn’t even populate outside of RW editor

I’ve attached a link for my site file as well as uploaded a screen recording.

I’ve published your project file to my server, which is a known entity, and everything is working A-OKAY here. I’ve recorded a short video showing it here.

You can visit this URL and use your credentials you made to login and give it a try: Editor | BullyHomestead

I suspect your problems have to do with your server setup. It seems you’re publishing to a Raspberry Pi, correct? This means you’re managing and maintaining your own server? Do you have access to a server on a major host like DreamHost or the like? If so, have you tested it there as well?

I haven’t tried elsewhere since I plan to strictly use the Pi. I don’t know what my problem could be. do you have any suggestions for where to start looking?

Running a server is something I have zero experience with doing. It isn’t something I’ve ever done or wanted to do as running one’s own server comes with sorting out its setup, maintenance, etc. That is why I pay for hosting so that if something like this needs looking into, the experts at my host can handle it. So this isn’t something I’ll be able to assist you with unfortunately.

Additionally, as an aside, if you’re going to be hosting a site via a Pi on your home network you’re going to want to definitely know a lot about your server and protecting it as doing it this way opens your network to the outside world. This is another big reason I pay for hosting as well.


Sorry, I’ve dug deeper and still can’t find my problem. Im looking into something else. Where should my posts folder be located? Since there isn’t one being created I want to try and manually Create the folder and add a post to it but I need the correct path

The posts folder would be at the top level of the folder structure for the site. That said, if it isn’t creating the folder then it isn’t going to save the posts in the folder even if you create it. You might check your permissions.

okay I got the editor working and all of the types folders populate. I didn’t realize I set permission for a different folder because I save backups of Rapidweaver there and wasn’t doing the same to the correct. However, I can see the post but my second page (blog) does not show them

Glad to hear you’re making progress on properly configuring your server.

The blog page for your project file works just fine here in my testing, as I showed in my earlier post above.

You can see it working here as well: BullyHomestead

This again leads me to believe it is related to your server unfortunately.

If you don’t believe it to be server related I would then encourage you to start a fresh test project and walk through the QuickStart videos replicating then exactly as a way to make sure everything is configured correctly. It is is still not working and you believe it to be Alloy let me know then and send me that test project file and I’ll test it here.

Saw your post on an 8 month old thread… if you want to share your current project file with us, I can look at it again and check it over, and test publish it as well just to make sure you don’t have any mistakes.

Did you try this?

Yes :sweat_smile: at this point I’m pretty sure its server related. I’ve tried every permissions setting possible, I’m just stuck at a brick wall with the entries not populating on the blog page. I just don’t get what in my server settings could be incorrect since literally everything else works


I’ll be in and out of the office tomorrow but if you send it over me I’ll take a look when I can.

AHHH!!! okay so I got somewhere, I added. anew page and made. a quick blog and that one works!! here’s the file with the ‘untitled page’ quickblog entry setup

it won’t let me upload the zip so here’s a link to download

This is my finally reply,

I got it working! I’m not exactly sure what the problem was but at any rate after fussing with it for a few hours it works!! Thank you so much for your help I’m so excited to start my blog!!!


Glad to hear you got it sorted. I suspect you had something configured incorrectly then if starting anew solved your problem. Hope you have a blast with your new blog. And be careful running your own server.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.