Button does not respond on iPhone

I am a bit desperate, in my footer, which I have designed (admittedly quite elaborately) with Cinema, Background and several buttons, the top button with the label “Senaste blogg-inläggen” does not work, and only on my iPhone not (!!!), on the desktop computer everything is ok. Only on the home page the top button works on the iPhone, but not on all other pages. I had first put the footer as partial on all pages, now I have alternatively put the footer individually, not as partial, on each page, but the button with the link does not respond. What is going on here? I can’t find a cause or a solution to the problem.

Here comes the link to the start page of my project (where everything works), and as an example the link to another page where this top button does not respond on the iPhone.

And here is the link to my project file at Dropbox:

Thanks for the help.

I’ll have to investigate this a bit further when I have time. Being the weekend I am not in the office. But it looks like you’ve got a lot of things layered in there in that footer in a bit of cacophony layout-wise in ways I don’t know that things were designed to do.

I know what you’ve got designed there is a bit unique, but maybe that is a bit of the problem. Like I said I can’t look over the weekend, myself.

1 Like

No problem, no stress, weekend and privacy is holy :wink: :innocent:
I can wait until next week…
Thank you for your quick reply

It took me some picking apart of your layout since it isn’t how I’d probably have designed it. That said… You’re using Overlap in two places. I’m not understanding your use case for the second one as it doesn’t seem to be doing much of anything. Needless to say that overlap is pulling the content below it up and you’re getting a whacky movement of your content. Remove the second overlap on the page and give it a try. I can look at why this is happening further later, but I think that should help your problem.

Thank you for getting into my complex layout. You are right, it is indeed the second overlap that is causing this problem. This overlap pushes the entire page content under the cross logo at the top left of the page. To achieve this I had to set the overlap at breakpoint extra small to a high value of 80. To demonstrate what this second overlap does, I reduced this value to 22 on the page “Integritetspolicy” (see screenshot1), in contrast to screenshot2, where I left the value at 80. With the value 22, the button in the footer also works again on the iPhone. But it would be nice if this design detail did not have to be changed and could be solved differently, probably somehow with z-index settings?

I would appreciate help, but I don’t want to take up too much of your valuable time. If necessary, I would change the layout and set the Overlap value to 22 everywhere. Or do you have other ideas? Thank you again for your precious support!

I have solved the problem, changing the z-Index of the footer with blacksmith. Everything works fine now. Thank you for your help and your fantastic work with the new Foundry!

1 Like