Can't resolve forms issue in Foundry 3

Hi, I can’t get my “form” to publish. I read about how it a php page on an html site. But being non-technical, that doesn’t help me. I tried deleting the pages and starting again, but that doesn’t help either because my original screwed-up pages are already published and I don’t know how to remove them. Is there a foundry 3 “forms for dummies” tutorial out there that will help me? Please.

You’re not wrong there @capack. It is a painful process setting up a form using rapidweaver and I wonder if some of the problem is to do with the hosting provider that you are using. I’ve been using Foundry forms in their various guises for an about 4 years now. Also using Super Form 2 from One Little Designer. In the last couple of days have discovered that my hosting provider (GoDaddy) is neither willing nor able to process Foundry 3 , 4 or Super Form 2 forms using a Microsoft 365 email account. So for me personally and in light of the fact that I have wasted so much time on this I have moved to Jotform. It’s free and works independently of either your hosting provider or WYSWIG editor that you’re using. It just works.

@capack what are you seeing? It’s hard to tell from your description where the issue is. If you have the new page with the form setup and showing in RW but not on your live site, it’s likely because you had previously published that page before adding the form to it.

Forms use PHP (code that runs on the server) and not just a static HTML page. When you add a form to an existing page, RW changes the extension from .html to .php. When you publish it, you end up with two files with nearly the same name. One will be index.html and the other index.php. When the file name is the same, web servers send the HML page by default to the browser, which is why would not see the form on the live page.

RW does not delete pages from your server. It only adds or overwrites existing files. You will need to login to your web hosting control panel and use it’s file manager to delete the index.html from the folder that holds your form page. You will see both the PHP and the HTML version in the folder. Again, just delete the HTML version.

At this point, your web browser may hold a cached version of the page, so you may need to quit and restart it.

Finally, if you post a link to the live page, we could have confirmed this was the issue in a minute or so. Without that, I’m just guessing at your issue.

Hope this helps.


Thanks, DinkyPixel. I have three different websites made with Foundry 2 where the forms worked perfectly. So this floored me.

Thanks for the detailed instructions, DLH. This was a brand new domain, so I don’t quite know why it picked up “html” on the forms page to begin with. Now, I just have to figure out how to log onto my host’s file manager so I can delete the html page.

If it was a brand new domain and you had not published the website prior to having the form on the page, then this it likely not your problem. Again, a link to the site in question would allow us to confirm we’re on the correct solution path. If you don’t want to post it, you can DM me the link and I’ll check.

1 Like

You can ignore the earlier suggestions in this thread. Your issue is not related to having both HTML and PHP pages on the server. For some reason the contact form is not loading on your server. This is why having a link is important, as it cuts down on guessing about issues.

You mentioned this is a new domain, You’ll need to reach our to your web hosting provider and ask them why the page is not loading. There is likely something not configured correctly with PHP for the new account/domain.

1 Like

Thanks, DHL. I found this out after my web host went in and deleted everything except my first three HTML pages. I republished all files with a new PHP contact form, and it still came out blank. I’ll contact my web host and ask them to take another look at my files. If that doesn’t work, I’ll try recreating my website in Foundry 2, and praying they’ll overwrite what’s already there.

Something is likely not setup correctly on this domain and you will likely have the same issue with F2. If you want to test F2, just create a contact page to test.

My F3 “form” page says “Call to undefined function random_bytes() in /contact/index.php on line 11” in my site’s error log. The web host couldn’t tell me what it means, other than to say it was the “error returned by that script.”

I published a contact form in F2 and it appears. So I’m wondering what the difference could be between the F2 and F3 code that is preventing the F3 form from posting? I should mention that I sent myself an email from the F2 form and I haven’t received it yet, so that could still be a problem.

What version of PHP are you running? I ask because that function was added to PHP in v7.x. If you’re using a PHP version prior to that, and you shouldn’t be, that could be your issue.

I have no idea how to find out what version of PHP I’m running. I’m using RW8 with F3.

PHP is Server-side, so you’ll need to ask your Hosting Provider (or check via your Host’s cPanel management portal.

That explains it. I was told: “It’s v5.6.40.” Thank you.

They should be able to update you to a currently supported PHP version. The updates are for functionality AND security, so it’s important.

Note that if you go to PHP 8.x, you’ll need your form to be using SMTP. The credentials/settings should be obvious, but again your Host should help, as will Adam’s documentation.

1 Like

I’ve resolved the problem using a Foundry 2 “form pro” stack for my contact form with the rest of the pages on my 4-page site created in F3. It was not the ideal solution, but my web host did not plan to update my server to a more recent version of PHP in the near future.

Thank you everyone for your help.

You’re going to want a new web host. That PHP version has security issues. They should be all over it.