Can't turn off 'Show Hidden Stacks' in library preferences

Hello. Im simply trying to turn off the Show Hidden Stacks option. I can’t find how…!!

Should be here in the Library:

image

Bildschirmfoto 2021-12-14 um 11.40.35

Screenshot 2021-12-14 at 11.44.23
It is, but I have no influence over it…not clickable. Its checked ‘on’ and I can’t turn it off.

This seems like a bug. I’m seeing the same here, and it can even be seen in @Fuellemann’s screenshot above. Maybe @Isaiah can take a look at this. He may already know of this bug’s existence or perhaps this is new news and related to macOS Monterey. What OS are you using @JohnB?

Yes, Im using OS Monterey 12.0.1
I did drop a line to the Stacks crew but as yet no reply. Thanks

I still have no reply from Stacks. Its quite annoying, the the library format with all hidden stacks open, and also having no reply/solution from either RW, Stacks, or Elixir.
Can anybody out there help?

@JohnB If this is a bug, as @elixirgraphics suggests, there’s nothing he can do about it. Ditto for the RapidWeaver team. This is all up to the Stacks developer. Unfortunately he has been missing-in-action quite a bit over the past few months. I know he’s had some issues to deal with … but I have no idea about his current status.

While you probably did email him correctly, I would suggest emailing/contacting him again and double/triple check you are providing the correct email. (There have been so mannnnnny times folks put in the incorrect email to him and other developers so this is always worth checking.)

1 Like

Ok, thanks for the info. I’ll re-email him

Hi @JohnB

I have replied but as @mitchellm points out it is completely out of my hands. I have zero control over it. That falls completely on @isaiah as he is the Stacks developer. I am very sorry he hasn’t gotten back to you. But I don’t have any control over whether he replies to emails, forum posts, etc unfortunately. :confused:

Yes, Im sorry to suggest you didn’t reply…wasnt my intention. I just re-emailed Stacks, thanks.
Kind of wondering if anyone else has the same problem…
Thanks for your hasty reply, again.

Like I mentioned in my earlier post, I too am seeing this problem. It is definitely a bug. I hate to suggest this for support but maybe use Twitter to contact @isaiah as an alternative. I’ve seen he’s active there from time to time: https://twitter.com/isaiah

Ok…funny, I just replied to an old friend that I couldn’t open the link they sent me 'cause opted out of twitter a few months back, & feel all the better for it.

So I do think this qualifies as the first OS specific bug I’ve seen. I believe something has changed in the way macOS enables menus – and it seems to be keeping several of my menus disabled all the time.

Someone mentioned this to me a while ago in a support email – but my normal development machine is back a few versions of macOS (it makes it easier to compile for some of the earlier versions of macOS).

But currently I’m traveling and using my M1 laptop (I’m 1000 miles from home “dropping off” my son at university) – I’m here for a long weekend to buy him better winter clothes. Growing up in Austin and California he’s not really prepared for snow.

Anyway on the other machine I was never able to see the problem. On this one I can see nothing but the problem. So some difference either Intel vs. M1 or the more likely Monterey seems to be triggering this.

I’m working on a bug-fix update currently, so I’ll make sure this fix gets added – I doubt it will be a very difficult one.

In the meantime, if you’d like a sneaky way to change the setting, you can do it with a bit of Terminal magic. Open terminal and try this to enable hidden items:


defaults write com.realmacsoftware.rapidweaver8 stacksLibraryShowHidden 1

Or just switch the last character to a 0 to keep hidden items hidden, like this:


defaults write com.realmacsoftware.rapidweaver8 stacksLibraryShowHidden 0

5 Likes