Form Pro not working

I get error message ( Mailer Error: Could not instantiate mail function) when sending a mail.

I had the legacy version of form pro and exchanged that with the new version of form pro and problem is on both.
I deleted the old one.

After sending the mail I get this strange url that ends with stacks in…

Url to the form

I have total CMS on the same page if that has something to do with it. It did work before so strange.



You’ll want to make sure your host has PHP’s mail() function enabled for your hosting account. You can also enable the “Send using your email” feature that is located toward the bottom of Form Pro’s settings, as some servers require you to send your for submissions using an email address registered to that specific domain.

1 Like

It worked using the email adress registered to the domain.


Sorry if I’m coming into the middle of this conversation, but I just today purchased the Potion Pack and its Form Pro stack says it’s the “Legacy” version. That implies it’s an older version and that there’s a newer one, but I don’t see it in the Potion Pack stacks list.

Am I missing something, or is it just a labeling issue?

Thanks in advance for any info.

Have you tried checking for updates with the Stacks updater in RW?

1 Like

Hi there @Noah

As @David suggested above, check for updates to make sure you’re on the latest version. Also, the Legacy version will show on any projects created with the legacy version. If you drag and drop a Form Pro stack from the latest version of Potion Pack onto your page you should get the non-Legacy version.

Everything was up to date, so I have no idea why the legacy version appeared. However, when I dragged another instance of the Form Pro stack onto the same page, it showed up as the current version. Why it changed, I don’t know. But as long as it’s now working, it’s all good.

All, except – now I can’t get the form to send emails.

I recall having the same problem last year, and it turned out that the domain needed an “” email address for the form to use as a “From” address. So this time, I’ve got that issue covered and there’s an “info@” email address. But the form still doesn’t send emails. It must be a different issue this time. Any ideas? Thanks in advance.

Have you tried using the “Send using your email address” option? If so, does the email address you’re sending to match the domain name? In other words, if your website is, are you using an email address with the same domain, such as


1 Like

I tried that, as well as everything else I could think of. I never got Form Pro to send email.

However, I installed the plain-vanilla Form stack from Foundry on the same page of my site, and it sent email fine.

I checked to make sure that all the settings were the same for Form and Form Pro, and I didn’t see any difference between them. I’d rather use Form Pro if I could get it to work, but as long as I have a working form on the page, it’s good enough for now. Longer term, Form Pro has more features that I’d love to use.

@Noahdoes When using the “Send using your email address” feature does the email address’s domain name match the site’s domain name?

Hi, I encounter the “Mailer Error: Could not instantiate mail function.”
However, only Android users are getting this error, tried this on several browsers on Mac, iOS, iPadOS, Windows and Android.
This error pops up when using chrome, firefox or edge on Android, all others work fine.
Working with Rapidweaver Classic 8.10.0, Foundry and Form Pro 2.1.5

That error is a server side error and should not have anything to do with a specific browser. Have you made sure you’ve setup your SMTP settings properly? Sending with an email address with a domain name that matches the site’s domain name?