Forms pro not working

Hi Everyone - I’ve been having a lot of trouble with Forms Pro and at this point things are unfortunately getting urgent :frowning: I initially had two forms on a page. It actually worked (for me) but was seemingly an issue for others.

I removed the second form and put it on a draft page for safe keeping. At that point, I thought that would be the issue. It’s not. I’ve double checked the email address, checked off ‘Send using your email address’ and republished.

I then went to use the form, got a ‘Success’ message, but nothing shows up for the client. I’ve been given access to the clients gmail account so I can see things as they happen. I sent a regular email to it and it showed up instantly. The most troubling part is getting a ‘Success’ message when nothing shows up. We tried the form using my wife’s Window compute wit both Explorer and Chrome. She got a success message as well, but nothing is there.

The form is meant to be used to upload short videos (less than 2mb, usually. Since this initially worked for me, I assumed user error on their end (older target audience :slight_smile: but now I can see it’s been inconsistent.

My last thought was that instead of publishing changes, I would erase then republish the website. Still, there are issues. I know it’s a holiday weekend, but if anyone has a clue I would greatly appreciate it!

Thanks in advance

So gmail is a tough thing. They block a lot of stuff.

You mention using the “Send using your email address” feature, but you’re sending the email to a gmail account. So that isn’t going to work. You must use an email address that has a matching domain name to the site you’re sending from… Let me give an example:

If your site is hosted at then the email address in the Your Email field needs to be associated with that domain. For instance

If you’ve got a gmail address in the Your Email field then that email and the domain of your website obviously don’t match. That’s a problem. This is something that’s been covered here on the forum many times in the past.

My suggestion would be to use the “Send using your email address” feature and make sure you’re having the email sent with, and to, an email address associated with the domain, as I outlined above, in the Your Email field.

Side note, don’t for get to put your threads into the proper category. I’ve put this one into the Potion Pack category for you this time around. :+1:

As Adam said - then use an email forwarding from the email Account from your Domain to the gmail account.


Hi Adam - thanks for your quick weekend response. I’m thought I just fixed it but I’ll try your approach. What initially happened (embarrassing) is that I didn’t create an email to begin with :slight_smile: Newbie stuff, I know. I don’t have a ton of experience with all of this but I’ve never had a form problem in the past - mostly because I’ve always created an email address for the domain in question. This is the first time I didn’t. It just dawned on me that the form needs to be sent by an address as well. I thought the email address that’s input in the form would handle that (silly in retrospect I know).

Side note to the side note - I typed in my problem and looked through the links that popped up regarding similar queries, and nothing that was helpful showed up. With regards to getting things in the proper part of the forum, all of the stacks show up together under Foundry. It’s easier for you to know if they are part of Potion Pack or not - you made them! I’ll pay attention to how they’re tagged so I can get things in the right place. Thanks again for your help!

Ooops. Yeah, the form definitely has to have somewhere to go. This should be covered in the Form Pro DOCs for the Your Email field, but if you don’t see it there, let me know and I can update it.

Not to be argumentative, but they’re sorted out into their respective packs in the Stacks Library. :wink:

CleanShot 2020-05-23 at 16.59.46

There’s a header at the start of each section. Potion, Thunder and Alloy all have separate headers in the Library.

That said your original post wasn’t in a category of any kind, Foundry or not. Like I said, it isn’t a problem. It just makes a little more work to have to go back and categorize things later so that people can find stuff in the future. No big deal.

Hi Again -

I went t o the video, not the DOCS - maybe it’s because your voice is so soothing when I’m stressed out lol :slight_smile:

Not to argumentative when you’re not being argumentative, but I put all of my stacks in a sidebar folder called Foundry :slight_smile:

I set things up differently than you - I have a million stacks (I’m working on weeding them out) but in the meantime this seems like the easiest way to get to them. Just found out about the Stacks keyboard shortcuts - it’s kind of exciting :slight_smile:

I think when I have a problem I panic a bit and click on new topic immediately. Not your issue, but UX-wise maybe it should force the user to select where it goes before you start typing.

I certainly don’t want you to do more work than you have to - personally I think you do too much (weekends, holidays, etc). I get that as I’m mostly self employed too. I also appreciate it! Thanks again.

Hello Mr. Fuellemann - I wish I knew how to pronounce your name :slight_smile: Thanks for the tip. I ended up using the ‘CC this address’ field in the settings to have whatever was sent to also go to gmail. If you read below, I’ve never had this problem because I’ve always created an email for someone at their domain. This person wanted a gmail account and I didn’t put 2 and 2 together.

1 Like