Foundry and Nick Cates Photo Stack bug?

Hi Adam,

I keep getting a loading alert (only on an iPhone) when trying to initiate the Light Box with Foundry and NCD’s Photo stack. Only seems to happen when I scroll down to the last image and try to initiate the Light Box. Seems a bit random I know but has been very frustrating.

The alert is “A Problem occurred with this webpage so it was reloaded”

I built a test site with a different number of images to see if it was related to the number of images, doesn’t happen until the amount of photos hits 9 or more. I also built a test site to see if it would happen with a NCD theme and I don’t have the same problem. Here’s the site for that.

I can send project files if you’d like just not sure how to do that.



Strange, when I visit your pages, I do not get the error you’re describing at all. I’ve visited all of the pages in the sample site you sent and haven’t been able to recreate the bug. I’ve used Safari, Chrome and Firefox, as well as tried it out on my iPhone and iPad.

I was afraid of that :slight_smile:

Can you try another thing? On your iPhone can you “Clear History and Website Data” on Safari and go to the 12 images and scroll to the last image and try again?

What iPhone do you have? I’m using an iPhone 7 Plus. I tried my wife’s 7 and it did it some of the time but not consistently like my 7 Plus.

Here’s the error I get. Thanks Adam!

I’m also on an iPhone 7Plus. Did as you asked, cleared everything out and visited your pages again and still haven’t run into any problems:

Thanks for looking into it Adam. Must just be something weird on my iPhone.

I’m not sure. If you’ve run into it on other phones I wouldn’t say that with 100% certainty. It is just hard to troubleshoot when I can replicate it, which makes it hard to tell what it is that is causing the problem, whether it is the device, Foundry, Photos or something else. :frowning:

Hey Adam,

I wanted to check in with you again about the gallery loading issue. Here’s a thread on the Realmac Forum I found. Would you mind looking at this? Not too long.

It happens all the time (for me) with Nick Cates’ Photo Stack and only some of the time with the Foundry Gallery. Nothing consistent that I can figure out.

And, would you mind trying another gallery page on a different site to see if you get the error code? This is Foundry with Nick Cates’ Photo Stack.

Thank you!


I’ve not looked at it any further since my last reply because I cannot replicate it here to try and troubleshoot the issue you’re seeing on your end.

As that thread points out, it is likely an iOS problem. If someone can help me replicate it here I’d be more than willing to look at it, I just need some way to cause it to happen so I can troubleshoot it.

And, would you mind trying another gallery page on a different site to see if you get the error code? This is Foundry with Nick Cates’ Photo Stack.

I loaded that site on my iPhone and iPad several times and scrolled through the page multiple times. I got no errors unfortunately any of the times I tried:

Thanks for looking Adam. Just to be sure, there were no errors when you tried the light box on that page?

Using the lightbox I get the error, yes.

I still don’t get the bug with the Foundry Gallery page though:

Ok. Thanks for looking again. I’ll be switching everything over to the Foundry Gallery now :slight_smile: