Foundry Sort-Stack

Sort Stack: Buttons “Style Buttons” dont work if the option “Attached to Search Field” is activated in Settings.


Hi @Gerhard – Are you referring to these settings?

These color pickers are for the Filter buttons, as seen here:


They’re not for styling the Search Bar buttons.

I’ve just built the quick test above and previewed it and the Filter Buttons take on the correct colors even when the Sort Buttons are attached to the Search Bar.

Maybe misunderstood?
The buttons are not clickable with this option
The search field does not work either

:slight_smile: Gerhard

Sorry I didn’t get back to you sooner – I’ve been out of the office for the day.

As for the buttons working or not when attached – They seem to be working fine for me here: CleanShot 2019-10-11 at 15.17.29.mp4 • Droplr

If you’d like to provide me your project file I’d happily take a look at it.

Hi Adam,
No Problem here the Link:

:slight_smile: Gerhard

Just opened up your project and tried it out. Seems to be working fine here: CleanShot 2019-10-12 at 16.20.32.mp4 • Droplr

Hi Adam,
see Screencast on my Mac
:slight_smile: Gerhard

Unfortunately this is what I get when I click your URL:

That said, the project works without a problem here. If you’d like to retry your screencast I’d be happy to look at it, but so far I can’t get it to fail here.

Hi Adam,
sorry, was on the way. Unfortunately, my FTP test server has a problem.
I zipped the screencast and put it on the FTP server. Attention he works very slowly at the moment :wink:

Here the link: Download

If you’d like to send me your latest copy of your project I can take another look, but the one you sent me before worked A-OK here.

Is exactly the same page, I used this page and recorded the screencast.


When I open your project things are a little weird, in that you have Pair with Parent Banner turned on for your Navigation Bar, but have no banner. So I have to turn that off to keep that Navigation from overlapping your Sort stack. When I do that, and can then see your Sort stack’s search bar, I can then freely click the buttons without any problem.

My advice would be to disable the Pair with Parent Banner feature that you’re not using and see if that clears it up for you. Apart from that mess up with your layout I don’t see any problem with those buttons here when I test your project file.

“Pair with parent banner” was it :-))
At this point comes a banner, so I had already activated this option. Obviously, this option then prevents the click.

Thank you for your effort - Great support
Best regards

It doesn’t prevent it, it just was overlapping your search bar because you enabled it but didn’t have a banner to pair it with. Simple mistake of enabling a feature that couldn’t be used. Glad you got it sorted out. :+1: