Host Google Fonts locally in Voyager Pro Theme

Hey guys! I’m Andrew from Austria. I have some issues with the gorgeous Voyager Pro Theme and Google Fonts. Maybe you can help me out!

In Austria we have some troubles with the law (also in Germany) because Google Fonts saves the IP-adresses of users and that’s not allowed here in terms of privacy.

So I tried to find a way to save the fonts locally. But it doesn’t work! If there is no way to do that because of the theme, I have to close the website. That would be very bad because it’s a big one.

Can anyone tell me if there is a way to do that? I was looking for a solution about a week and tried some things out but didn’t get it work.

Thank you for helping me!

The fonts I provide in the theme itself are all local to your site.

Are you referring to these or are you referring to fonts you have personally added to the site?

Hi, hast Du im Browser mal geschaut, ob die Fonts wirklich von dritter Stelle kommen? Sonst gib mir mal die URL, dann kann ich nachsehen…

Hi! Danke für Deine Antwort. Ich habe das geprüft, aber wenn Du nochmals nachsehen könntest, wäre ich Dir sehr verbunden.

Webseite

Danke!

Thanks for your comment! I’m referring to the fonts in the theme itself. If they are local to my site then I don’t know why they are connecting to “https://fonts.googleapis.com” or “https://fonts.gstatic.com”.

Maybe there is an other problem here? Any ideas?

Thank you!

Here’s a look at the internals of the theme. You’ll see the fonts here:

And here’s a look at where I load the fonts in the theme within its CSS:

Here’s where FontAwesome is being loaded locally, too, in both the CSS and Head.

Same goes for the optional fonts in the various CSS files that make up the theme’s font options:

I suspect you’re using a stack or something else that is making a remote call to Google for a font perhaps, or something else on the page. If you want to share project file here maybe someone can look at it and help you.

Provide us a copy of your project file please, along with a link to the live site.

Create a ZIP file containing your project file. This is the file you open in RapidWeaver to edit your site. After creating the ZIP file, upload it using a service like Dropbox, WeTransfer, Droplr, or a similar service to create download link for us. Paste that download link in your reply.

Hier sieht Du alles, was von extern kommt:

In irgendeinem stack lädst Du also fonts, und auch maxcdn… kommt von extern. Schau mal ob Du in Stacks alles auf lokal gestellt hast:

Die unteren Sachen dürfen alle NICHT angehakt sein.

Thank you for your detailed information. I took a quick look in the themes content and I didn’t find any fonts. Why is that?

Maybe that is the problem or an other stack.

I try to figure this out.
Thanks for your efforts!

What version is your copy of Voyager Pro? When did you purchase Voyager Pro?

You can find the version number in the Addons popup window, here:

Hi! Danke Dir! In welchem Stack ich die Fonts lade ist mir immer noch schleierhaft.
(meine Stacks habe ich gerade gepostet)

Stacks_preferences

Ich habe aber alle auf lokal gestellt.

Mal sehen, warum im Theme Content keine Fonts drinnen sind und welcher Stack die Fonts lädt wenn nicht das theme selbst.

Was ist denn bitte maxcdn?

Danke vielmals für Deine Hilfe!

Thanks for the quick answer! Here are the screenshots:

Seems like I have an old Version!

That’s why, you’re using an old version. Click that download button. You should get the latest copy in the download. Drag-and-drop it on the RapidWeaver icon in your Mac’s Dock. Once installed, restart RapidWeaver and re-check the version number. Should be v1.5.0. After checking to make sure you’re updated, do a Republish All Files from RapidWeaver.

Thank you so much! I will try that and reply to you soon. Thaaaaanks!

The theme’s were updated in 2018:

When I did so I sent out emails to all customers and walked them through how to download new versions of the themes. I suspect you simply never got the email. Probably due to spam filters or something else.

I had a backup of the first downloaded theme. Two months ago I got a new MacBook and installed a clean new version of rapidweaver (v.8) on it. Maybe I did the Update on the old Mac but forgot to change the backup file.

Thank you! You are great! I enjoyed to work with your product all through the years.

2 Likes

So you’re all sorted out then? Updated to v1.5.0 with no problem?

If so I’m glad to hear it and glad we could assist you.

1 Like

Sorry, new users cannot replay so much in one day. :frowning:

Yes sir!!! That was the problem! I thank you so much for your help. Sometimes it’s just a little thing that causes big troubles.

YOU ARE GREAT! THANKS AGAIN!!!

1 Like