Image inserted into body of blog does not upload


I know this topic has been posted and resolved by someone else. That involved Topper and images inserted into blog. My Blog is test published with one brief post. In doing this post, I was able to upload the topper But I can’t insert an image into the body of the blog, regardless of the method I try.

I read through the previous post on this topic. I noted the suggestions you made and read that the problem, in that case, ultimately was non-matching URLs in General Settings.

Steps I have taken:
-Initially, I could not upload the Topper or images. But I found that the URL in my General settings and publishing settings did not match [https vs http]. I corrected that and was able to upload topper. However, the inserted image still does not appear.
Per other suggestions-
-The Editor page is not the home page. It is the next page after home page [page 2] Editor | Robert Safion, LMHC
-photo name contains no numbers and image size is 61 kbs
-php ver 8.0 .
-I am unclear about the path requirements that were referred to that other post. I use Omni Hosting [not great but after I fix this I will change] I will contact them this evening and ask if they see anything. Typically, they are not exceptionally helpful.

If there is anything else you might suggest in the meantime, let me know. I will update after contacting Omnis

Many thanks in advance for you help and , above all, your patience

As a place to start – try setting your PHP version to v7.4. Alloy is not designed to work in v8 at this time.

After updating to v7.4 you’ll have to give your server a while to revert to the previous version.

Thanks , Adam
I’ll give that a go tonight and report back

You might also go back through the QuickStart video and follow along step-by-step replicating what’s in the tutorial.

Changed PHP back to 7.4. Tried inserting another image using the insert image from Editor, but no joy. Topper still shows but not image in blog post

So, I’ll go back and watch both quick start tutorials and contact hosting service tomorrow. I’ll report back after taking all those steps. Clearly, I am missing something here
Thanks again

1 Like

Believe problem is fixed. It was a URL issue, apparently

Went back into my URL settings. They were identical. Repeated published site, and noticed that the “view site” gave me an error message. In another tab google myself and site opened. Toggling back and forth between the working and error tabs I noticed that URL of error message was HTTPS while the working site was HTTP.

I tried uploading with both the HTTPS again and got an error message that my software [RW?]
was not compatible with HTTPS, which is strange bc RW has that as a drop-drown option. But didn’t give a s**t about that [it was 2:30am] and went down the path of least resistance.

I set both to HTTP and reloaded. Made sure that the image I was using was in my resources folder-something I had already done- and it worked! The formatting is screwed up. But I haven’t set blog up for columns or anything formatting stuff like that. Having the Topper and embedded images both appear was the important thing.

Does all that make sense or sound right to you ? If so, I believe I can move on to design/formating . Not sure about the HTTPS issue, but will deal with that later.
If you aren’t comfortable recommending a hosting company on this platform, I understand. But I am looking to switch

I will await your comments

Thanks again !

Yeah, that will do it. The URLs have to match up. Have you setup an SSL certificate for your site? If not you’ll use http:// if you have then your URLs should use https://

As for a host – I have no problem offering up my preferred host. I have used DreamHost since somewhere around 2006 or 2007. I’ve rarely had anything go wrong, and the very few times I have the support from DreamHost has been quite good. I find their system to be easy to use and their documentation knowledge base is thorough as well.

You can visit their site at

Actually, I don’t have an SSL certificate for my site. I should. So, I’ll research how to set that up and then switch to https://
This is probably why my FormsPlus stopped working. Your Forms Pro bailed me out. Great contact form. Intuitive, very easy to use, but I need something a bit more robust on the form’s side.

Hey, if you ever develop a comparable contact/forms add-on, I’d jump on that, as would many. I prefer to stick with Foundry as much as possible. Mason and Carpenter are great additions, I am going to dip into. Certainly, always watching for your new stuff.

I’ll give DreamHost a try. I am someone who would need occasional support and def a well-organized, complete knowledge base. Your recommendation is good enough for me!!

Adam, per usual, really appreciate the detail of everything you do and how helpful and responsive you are. It’s a real treat in a world that has become, shall we say, difficult

1 Like

Not a problem. Definitely get an SSL cert. DreamHost offers free SSL certs for their plans.

1 Like

Great I’ll do that with the switch over

Thanks for all Adam!