Issue with send button in Foundry forms

I have analyzed the error.
Sometimes the button works immediately. If it doesn’t react, you have to reload the page several times. In most cases it works after all. So the problem could have to do with the loading of the page or the form.

First Meassage:
Since a few days the send button of several forms does not work anymore. What could be the reason for this and how can the error be fixed?

I am using Ventura on mac mini

The description of the problem is the first step. Can you please give us a bit more clarity in regards to your statement “Since a few days the send button of several forms does not work anymore.”? In what way is it not working specifically? We’ll also need to see the page(s) in question.

Provide us a copy of your project file please, along with a link to the live site.

Create a ZIP file containing your project file. This is the file you open in RapidWeaver to edit your site. After creating the ZIP file, upload it using a service like Dropbox, WeTransfer, Droplr, or a similar service to create download link for us. Paste that download link in your reply.

Thank you for the quick reply and helpfulness.

With the iPhone, the button rarely works immediately. Often the pages must be reloaded several times until the button of the forms reigns.

With the Mac I could not send a form. Even after loading the page several times.
If you need more information, please ask me.

Here is an example with a Link to the website. There are lots of pages with forms.

Here is the link to the project file

Hi, I see that you are using 3 forms on the page. I think that will not work. Can you delete two of them and use only one?

1 Like

I am using these three forms for month and they worked perfectly until last Wednesday. Therefore, I think the reason is another. Since last week the issue is there. If I remember correctly a few days ago there was a foundry update.

And some days ago there were a Ventura 13 update on my Mac!

I’m out of the office as it is the weekend but as @Fuellemann states — one form per page.

One form per page can’t be the solution. I published another page with one form! And the send button doesn’t work too. If you interested I could send you the project file on Monday.

Best regards

I’ll look Monday when I’m back at the office. Send along the project. Whatever the outcome though you can on have one form per page due to how they’re made to work.

Here is the dopbox link to the other rapidweaver webpage with the form button that also suddenly stopped working. On this webpage is one form only!

Link to the page with the contact form

I would be happy if you could take a look at it on Monday or Tuesday. Again, the button sometimes works on the iPhone but never with my Mac on Safari.

Best regards

I’ll take a look at the project file tomorrow, but I just loaded this form up in Safari and Chrome on macOS Monterey and Ventura and in all four instances the form worked as expected.

Monterey (Safari): CleanShot 2022-11-06 at 15.26.52.mp4 - Droplr

Ventura (Safari):

Perhaps you have an extension loading in your browser, or something else on your machine which is giving you problems? I’ve tried many times now and it always seems to work when the fields you’ve marked as required are filled in.

Thank you for checking the website. I use the default Safari system. Yesterday I saw that you tested a form. It looks like Safari works for you (it doesn’t for me). Did you test the forms with the iPhone as well?

The other trailer rental website worked smoothly for many months with the three forms. Suddenly the form buttons stopped working. We had noticed this after several customers complained.

If the other Foundry users do not have these problems with the send Button, the error cannot be Foundry’s fault. Then I should reinstall all programs.

Yes, I also tried on the iPhone as well. You’re sure you filled out all of the required fields before submitting the form? The button is disabled until they’re filled out.

Reinstalling Foundry, Stack, RapidWeaver, etc will not change what ever is happening on your server. My suggestion would be to make a simple test page with minimal contents and test there. I don’t suspect it is a PHP problem otherwise the form wouldn’t have sent for me. Have you tried a different computer as a simple test?