Markdown file not found

Hi there,
We have been using Markdown documents on our service portal for a long time, and that has always worked without any problems.
Suddenly an error message is displayed (see appendix). Didn’t change anything on the site, the directory and the url are correct.

What could be the cause for this? I would be grateful for a tip.

:slight_smile: Gerhard

Hmm, seems like something changed, whether it is something you changed with your project or perhaps something with your host changed that you might be unaware of. Without knowing more and having your project in hand I can’t troubleshoot anything based on a screenshot alone, as that is just a message that the Markdown file cannot be found. This could be because of something your host has changed with how they allow access to files.

A few questions:

  • Is this markdown file on the same domain as the site you’re embedding it on?

  • Who is your host?

  • What version of PHP are you using?

  • Can you provide the following for me please:
    – A link to the live page.
    – A ZIP file containing your project file and Markdown file. The project file is the file you open in RW to edit your site. Once you create the ZIP file, use WeTransfer or a similar service to create a download link for me and include it in your reply to the above questions.

Any other details you can provide about changes that have happened with your project, your host, etc would be helpful.

Hello Adam,
Thank you very much for the quick answer, the requested information below:

:slight_smile: Gerhard

Thanks for your reply. Being that it is the weekend I’m out of the office until Monday so I probably won’t be able to have a look until then at least. I’ll test it here on my server, where I’m guessing it should work fine, but we’ll see. You might also in the meantime contact your host to see if they may have changed anything recently that would prevent you loading this file via CURL. also you might try making and Embed from the Editor if you haven’t already. Though it also works the same as the Markdown Embed stack.

Good morning @Gerhard

Wanted to check in with you…

I just got into the office and downloaded your ZIP file. Looks like you only supplied the project file and forgot to send the markdown file as well:

Any updates from over the weekend?

What did your host have to say when you reached out to them?

Have you given this a try?

As for your project file that I received – I’ve published a test to my server using that project, which you can find here:

You’ll notice some things missing, as I don’t have all of the stacks you’re using, as well as the fact that I don’t have your blog posts. But as you can see the Embed is working fine here, even cross domain. This leads me to believe that something with your host has changed that is causing your a problem. Especially if it was working before and then suddenly ceased to work. You’re definitely going to want to reach out to your host. You can also try building an Embed directly from the Editor and see if that works for your server.

Hello Adam,
was unfortunately on the road and therefore not in the office.

In the meantime I have an answer from the provider which, as expected, is as follows:

I can’t find anything that the technology has adapted on the server in the last few weeks that could cause this from our side. I would say you play a backup from the side when it was still possible.

In the meantime I have tested the following:

Linked to an MD document from the Alloy blog in the same project folder. - Result: the same error message. - In the alloy stack, however, all entries (folder: news-posts) work correctly.

New MD document created, new folder created on the server, new empty RW project created. In the new project (on my computer) linked with the MD_Import stack to the server - result: the same error message.

I haven’t been able to set up the editor yet, I’ll do it tomorrow.

For me it looks like all links from the MD_Import stack no longer work. In the appendix I have compressed both folders with all the documents.

:slight_smile: Gerhard (59.7 KB)

Nothing has changed in Alloy in quite a while. Last update was July 8, 2021 which did not touch the Markdown Import stack at all.

The last time I modified the Markdown Inport stack was November 25, 2020, nearly a year ago.

As I mentioned in my previous post, your project file is working fine here on my server, even cross domain importing your Markdown file from your server. If you have not updated anything and I have not updated anything, that leaves us to narrow it down to your host, which is out of my control unfortunately. Do you have access to a different host you can test on? If so I’d suggest trying that. You might also go back to your host again.