Nav bar not making changes global

Has anyone else had this problem? I’m sure it’s something I’m not doing right and it’s really getting to me now.
I create the nav bar using the Foundry stack and make it a partial. Then I add it to other pages and at first it seems to work, so I make a change and it changes the Nav on all the pages. Then a few days later I make a change and something must have gone wrong as it only changes some of the pages.

Is there something I’ve missed with creating partials or using them. Or is it a Navbar thing? I’ve gone through the partials video on the YourHead site.

This is the site I’m working on

Thank you!

This might be a question for @isaiah as it sounds like something that is occurring with the Partial itself.

OK, so, first off… let me make sure I understand the issue? It’s that you made some further changes to the navbar partial – and those changes didn’t seem to mark all the pages as needing upload. Correct?

If so, then this is kind of a long story. But before I get to that… a simple workaround is just to type Cmd-Shift-M or choose Mark all Pages as Changed. This won’t re-upload everything on your site – it just makes sure that RapidWeaver will export each page and look for changes that need to be uploaded – like your NavBar partial.

OK, longer version…

The truth is that when RapidWeaver 6.x and 7.0 were out this feature worked great… if you made a change to a partial, then all of the pages that utilized that partial would notice and mark themselves as changed.

But RapidWeaver 7.1 introduced some radical changes to the RapidWeaver API. One of those was to delay loading of pages in your site until they are absolutely needed. Unfortunately there wasn’t much help given to to plugins like Stacks that relied on those pages being loaded for some features.

For most features I was able to come up with a workaround that allowed things to mostly get handled the same was as pre RW 7.1 – but there just wasn’t anything to do for this one. It required a radical re-architecture of partials to make that feature work again.

I’ve been working on that – and I’ll be honest – even years later, I still haven’t completely managed to work around that one. But it will at least be far better in Stacks 4. In all but the a few corner cases it should do the right thing again.

Unfortunately there just isn’t a way to bring those huge changes back to Stacks 3. :frowning: I hate it when a “bug fix” is included only in a big update. But I swear I didn’t do it on purpose – it really was just a massive massive rebuilding of how these things work.


1 Like

Many thanks Isaiah for your comprehensive help and explanation.

Yes you are correct about the problem.

It does feel good to know the fault may not be me! And I will wait with baited breath for stack 4. Is there an estimated date of release?

If I re upload the entire site will that get round the issue? I hope not as I have already done this and the fault remains. I have also tried Cmd-Shift-M.

Many thanks again

You can always do a full Re-Publish All Files from the file menu. This will absolutely get the entire site back in sync. It just takes a while.


1 Like