Problem with Table(CSV)

Hi there and a Happy New Year 2020,
I try in vain to display a csv file in “TableCSV”.

As a result, I only ever get the title line including “;” displayed, no data lines.
Have attached a small csv in the attachment. How should the csv file be formatted? Tried some combinations (separators, line connections) but none worked.

Many thanks for a help
:slight_smile: Gerhard

TGD.csv (188 Bytes)

Your values are separated by semicolons rather than commas. Try it with the csv file I’ve attached to this message. I believe it will work.

TGDcommas.csv (190 Bytes)

Thank you very much, it works like this. In our countries at csv.Files the separator is “;” usual, but I can control that when exporting.

I have still one question:
Does the csv file have to be in the resource folder or does an external link also work: http: …
I was only able to test the project locally and an http link doesn’t work there(LoadingData…), but it does for pictures.

:slight_smile: Gerhard

I tried this and the reason it got stuck at “Loading Data…” was this:
Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at (Reason: CORS header ‘Access-Control-Allow-Origin’ missing).

If I exported all the files to the same domain (that is, the project files were at the same http address as the csv), then I was able to use a URL with no problem.

Thank you for the information, I can set it up so that the target folder (s) have the same domain.

Thanks for the support
:slight_smile: Gerhard

Glad to be of help.

One question: how are you setting up the file when referencing it through a URL?