Problems with Form Pro and smtp login

I have Office 365 and can not log in via SMTP. I have checked with Microsoft and the settings are correct, but TSL must be TLS 1.2. What is used in Form Pro?

Tried without logging in via SMTP, but it does not work. I use

Edit: Without SMTP I get this error message: Mailer Error: Could not instantiate mail function.

I’m not sure what Office 365 and Form Pro have to do with one another.

I believe inclusion of TLS v1.2 was dropped in PHP v5.6, so PHPMailer, which FormPro uses, tries to use v1.2 if possible, but the latest version of TLS is v1.3 I believe.

What version of PHP are you running currently on your server?

I am using PHP 7.4 on

I don’t know what that means. Is that the site you’re having problems with?

You did not elaborate on this… what does Office 365 have to do with this problem?

Yes. My site.

Possibly nothing. I mentioned it only because there are obviously major issues with Office 365 Exchange and external SMTP Server.

I’d encourage you to make sure you’ve configured your SMTP server setting in the stack correctly per your host’s guidelines. Also make sure you’re using an email address in the “Your Email” field that is associated with your domain, and that you have “Send using your email address” enabled as well.

If you’re having problems with your host’s SMTP server you will need to work with them to iron that out. That is not something Form Pro has any control over. I just tested SMTP support here on my DreamHost server and all if working as it should be.

Do you have any idea why it does not work without SMTP?

Sending emails can be tricky, as hosts and email providers lock things down pretty securely to prevent people from sending spam through their systems. This can make getting contact forms setup correctly more challenging.

I just setup a test using SMTP authentication through Office365 and it works just fine.

Some things you need to have set correctly:

Your Information - Email: This needs to be an email address that is part of your Office365 hosted domain.

Send using SMTP server: Checked
Username: Email account (address) that is part of your Office365 account.
Password: Password for that account
Port: 587
Security: TLS

Send using your email address: checked

In my test, I used the same email address in Your Information - Email and Username fields.


@DLH This is very strange. Have done as you describe, but it does not work :thinking:


EDIT: Get this error message: Mailer Error: SMTP connect() failed. Troubleshooting · PHPMailer/PHPMailer Wiki · GitHub

I can’t offer a solution to this, but…

I offer 365 as a service. I don’t get involved in it, beyond taking a cut, I pass all 365 work to the company who supply it (they also look after my servers etc.)

Just recently we had an issue with a client not getting emails sent via forms on the site, not a Foundry site. Regular emails worked fine, and on testing the forms sent emails to my Gmail email no problem, but not the email account on 365.

After some digging, we discovered that one of the settings in the DNS/Nameserver (not sure which, not my area of expertise) was incorrect. Once fixed emails started to land in the 365 inbox. Prior to this fix, the emails were routing to my catchall box.

So, the takeaway was 365 requires quite a lot of settings to be 100% correct at the domain end of things to work, and even the professionals get it wrong from time to time. If you want to check if this is your issue, check your catchall.

1 Like

Not sure what to suggest. My test was a brand new page sending through one of my Office365 domains. Your settings look similar to what I am connecting with. I wonder if your issue is with your hosting provider, since you aren’t able to send with ether method.

The server I tested on is running PHP 7.2.

Your host likely requires SMTP.

Have you tried changing the SMTP port to 465?

Yes. I have tried 465.

Ok. Was just a thought because I use 465 to send.

I have now deleted Form Pro in the project and added it again. Now Form Pro works.

I can now send emails from the website, without logging in via SMTP. Strange!