RSS feed validation

I have troubles with my rss feed, the link doesn’t seem to bee correct (see validation screenshot), and maybe this is the reason, why I have troubles with my newsletter-provider “mailerlite”??? It sends an EMPTY newsletter EVERY day, even if I didn’t post anything new in my blog, - and I can’t sort out why?!? Does anybody has an idea what is going on here and how to solve the problem?
Thank you all for any hints and help
Best regards

Alloy definitely creates valid XML for RSS feeds, so I suspect something is amiss with your setup. Provide us a copy of your project file please, along with a link to the live site.

Create a ZIP file containing your project file. This is the file you open in RapidWeaver to edit your site. After creating the ZIP file, upload it using a service like Dropbox, WeTransfer, Droplr, or a similar service to create download link for us. Paste that download link in your reply.

As an aside, the error your screenshot shows (IRI found where URL expected) is referring to the non-ASCII characters in your post title, which is used for your blog post’s ID. You can set a custom slug for the post that uses only ASCII characters, or change the post title to one that conforms.

Hi Adam,

thank you for your quick reply!
Here is the dropbox link to the project file:

and the URL of the live site (blog):
I am still testing the site, especially the newsletter function with, which should send only new blog posts, following the rss feed, but which sends every day an empty newsletter.
<![CDATA[RSS Feed kristensamfundets blogg]]>

Thank you very much for your help and patience!
Best regards

Did you try making the change(s) I suggested above? What was the outcome?

Yes, but the validation is still with the same error message. And I will have to wait until tomorrow, to see if the daily empty newsletter will be sent again - I am afraid it will… :frowning:

It doesn’t look like you have changed to a slug that contains only ASCII characters. The feed still shows the non-ASCII character:

You could likely also use Pretty URLs as yet a third option as well.

I had changed the slug of the post title to non ASCII characters, please check now again:

… but my changings in the editor (embeds, posts, droplets) take about 30-45 minutes, until they finally appear on the website! There is generally something very strange going on with the whole setting of my alloy-blog, the rss feed and the editor.

Tomorrow I will tell you if the rss feed makes my newsletter campaign send again an empty email, even though there are no new posts. I have no idea what is going on here?!? Thank you for helping me, I don’t know any more what to do.

Sounds like you have a caching service like CloudFlare. I personally do not like CloudFlare.

XML file still shows the same slug.

Please send me the markdown file of that blog post.

Sorry I can’t help with that, as it isn’t something I support.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.