Trouble uploading .gif in Alloy blog posting

Trying to upload a .gif image and keep getting this.

Screen Shot 2022-12-02 at 2.21.18 PM

Strange. Alloy’s blog posts can definitely handle .gif uploads. Just did a sample here if you’d like to see it in action (

And believe it or not you can even use them for the Topper, though I don’t know if I’d recommend it as .gifs are pretty large in size.

Care to share a video with us like I did above so we can see your process? You can also share your gif file and we can give it a look, too.

Create a ZIP file containing your gif file. After creating the ZIP file, upload it using a service like Dropbox, WeTransfer, Droplr, or a similar service to create download link for us. Paste that download link in your reply. You can do the same for your video recording too if you like.

Thanks Adam.
Tried both the upload and drag and drop methods, as you can see in the screen recording.
zip has video and gif.

Not sure what to say here – I just did a test using your .gif and it uploaded as expected. :thinking:

You can see it here: CleanShot 2022-12-02 at 17.41.53.mp4 - Droplr

Perhaps it is your browser? What browser is that you’re using there? Have you tried it in Chrome? Safari even?

Shoot. No. Will try in safari and check back,

1 Like

Tried it in both safari and chrome. Got the same issue.

Tried a different gif but same problem.

I don’t believe that this is an Alloy issue. I can consistently upload gifs, including yours you’re experiencing trouble with, and have no problems.

hmmm. Ideas on what could be the issue? Hosting?
I don’t do Cloudflare so it can’t be that.

That message is not being generated by Alloy itself. It looks to be coming from the browser. My guess is it is related to your server as that is the main difference between our two setups. So you can look into that if you like. Maybe test publish to a different server if you have access to one.

which version of PHP is compatible with Alloy?

Alloy can be used with PHP v7 and newer.

upgraded my php to 7.4 and it seems to be working now.
FOLLOWUP QUESTION: Will Foundry (Alloy too) work with 8+ PHP?

As I said above Alloy works with PHP v7 and newer. This includes PHP v8.