Using Non-Standard Fonts

See sleep RE the following Q…

I would prefer to use SF Display Pro as my Font. I’ve put it into place in the Foundry Stack, and I’ve made the appropriate selections within the Control Center, but it still shows up as something other than the Font I prefer. How to fix?

Initially, to overcome my lack of knowledge in this area, I employed images I created with the Font I want just to get my prototype done for review. Now I need to go back and replace with real text in my preferred font.

Thanks to anyone offering guidance.

Have you watched Adam’s comprehensive video tutorials on the Typeface stack? They walk you step-by-step through the end-to-end process to self-host fonts (best for GDPR) - it’ll take you from zero to expert very quickly.

I’ve watched several of the videos, however, I may well have missed that one, so I’ll check it out.


Great help, but I’m not there quite yet. I’ve studied the video numerous times. I’ve converted the fonts of my choice, 4 from Apple SF Pro Display and one .ttf Roboto to .woff files.

I’ve put those converted fonts into my Resources Folder, and I’ve placed the typeface stack on my page under my Foundry Control Center.

When I try to place a font from my resources into my typeface font, no go. It will not accept any of my converted fonts from my Resources.

Any thoughts recommendations for me?

Best if you share your project file with us so we can see what you’ve done first-hand.

Create a ZIP file containing your project file. This is the file you open in RapidWeaver to edit your site. After creating the ZIP file, upload it using a service like Dropbox, WeTransfer, Droplr, or a similar service to create download link for us. Paste that download link in your reply.

Noted. Thanks. I’ll gittr done.

Here’s Dropbox Zipped file for review…

I have to admit I’m a bit confused. I don’t see Foundry’s Typeface tool on the page at all and I don’t see any font files in the Resources folder. You followed the Typeface tutorial videos step-by-step, replicating what they show, correct? If not, go back and watch those and follow along with them.

I just uploaded two screenshots of what I sent…

This is what I have from you @NeilMike

Entire page:
Entirety of your Resources: CleanShot 2023-01-19 at 16.04.34.png - Droplr

I’m not sure what is being asked, if anything. I’m looking at my response to you in/ on the Support page, and it shows the two screenshots I sent clearly. The first one intended to show that I have five fonts in my Resources in my RW file, when your response was that I do not have any. The other image in this support docs clearly shows my Foundry Control center in my project file and right below it is my Typeface stack just inside of my Foundry Container that I’m using.

So, I guess now we are both confused. I’m happy to keep trying, but it is appearing that none of what I’ve tried, zipped RW project file and two screenshots uploaded have yet to work.

I saw your screenshots, and they do not match mine. Yours shows Typeface in the project file, yet the project file you supplied me does not have it on the page. Same goes for your Resources. Your screenshot does indeed show the fonts included in the Resources, but again the project file you supplied me does not contain those fonts.

I’ve put your screenshots next to mine to show the difference:

You’ll notice in my screenshot the project file you supplied does not have Typeface included.

You’ll notice in my screenshot the resources section for the project file you supplied me does not have your fonts included.

I’m happy to troubleshoot your project file and figure out where your mistake is, but if I don’t have the project file setup the way you are saying it is then I can’t troubleshoot it for you.

My guess — you simply sent me the wrong project file, or didn’t save it before zipping it up and sending it.

By jove, I think I’ve finally “got it.” It took a number of additional reviews of the Typeface video, but it seems to have finally worked its way into my hard head. Thank you so much for your patience with me and the valuable guidance provided.

Adam, sorry to bother you again (so soon), however, is there a way to execute a subscript, e.g., the 2 in CO2, in RW?

I would just enclose the “2” in the subscript (sub) HTML tag.


Cool. I’ll try that. Thanks.