Vertical tabs not working after changing htaccess settings

I have just changed my htaccess security settings (see attached code), and now the vertical tabs on the site with my legal notes, terms and conditions etc. doesn’t work any more correctly:
If I delete the htaccess code again, the vertical tabs works again, - so it must have to do with the settings in the htaccess code. Can anyone tell my what is going on here and what I will have to change in the code?
Thank you all for any help and support!

Here is the code I have set in the htaccess-file:

RewriteEngine On

RewriteCond %{HTTPS} !=on

RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

Header set Content-Security-Policy “frame-ancestors ‘self’; base-uri ‘self’; default-src ‘none’; form-action ‘self’; img-src ‘self’ data:; font-src ‘self’ data:; object-src ‘none’; script-src ‘self’; style-src ‘self’;”

AddCharset UTF-8 .html

Header set Public-Key-Pins “pin-sha256=“base64+primary==”; pin-sha256=“base64+backup==”; max-age=5184000; includeSubDomains”

Header always set Strict-Transport-Security “max-age=31536000; includeSubDomains; preload” env=HTTPS

Header always set X-Content-Type-Options “nosniff”

Header always set X-Frame-Options “SAMEORIGIN”

Header always set X-Xss-Protection “1; mode=block”

Header set Referrer-Policy “no-referrer”

PS: But the code gives me a good result when I check the website with webkoll

Hi just open Safari and in the page inspector click the console tab. You should see a red warning which tells you what went wrong. Tell us here.

Thank you for your quick response. I didn’t know this function in the page inspector yet. Here is a screenshot of the errors. Does that help to understand the problem?

Hi you will need to add 'unsafe-inline' to the style-src and the script-scr.

Thanks for this recommendation, but if I do that I get a complete chaos on my website (screenshot1), so I have changed it back to self for to get back to how it should look like (screenshot2).

Perhaps you just needed a republish all. Send me the complete htaccess via pm and I sent it back