Video Embed generates "Video Unavailable" on YouTube

I’m a beginner and I tried to use Video Embed to put a YouTube video onto my site. I just used the YouTube ID number, not the full URL in the “YouTube ID” field.

The video turns up on the webpage, so I believe the connection to YouTube is OK, but when I try to play the video I get a “Video Unavailable” message, both in RapidWeaver and on my Safari preview.

My YouTube video was marked private, but I changed that to public and there is no change.

There doesn’t seem to be much in the way of controls with Video Embed so I’m not sure what else I may have done wrong. Does anyone have any suggestions?


I have seen this only today when I first used the embed stack. A bit of experimenting indicated that is was not anything to do with the stack. Just using a html stack with the youtube supplied embed code resulted in the same issue. Same with a different theme other than Foundry. Same with styled text page.

So I think it is some sort of youtube issue.

If you provide the URL for the video others of us can double-check for you. Additionally provide us a link to the relevant page so we can see if the problem shows up for us.

It’s also possible you did not empty your cache. If using Safair you can do this under the Develop menu and select Empty Caches. Then refresh the page and see how it works.

I’ve never had any problems (YouTube or Vimeo) with the video embed stack. So I’m guessing there’s some small mistake happening on your end, but not sure what it is.

I’ve just added a Video Embed stack to a new page and the default YouTube video seems to play just fine. I’d suspect as others have talked about above that the problem was on YouTube’s end. That said, as @mitchellm mentioned, if you send us a link to the video one of us and try it out on our end.


I created a html file with “vi”, using the standard youtube embed code, taking Rapidweaver out of the equation altogether and the issue persists. Multiple browsers, multiple OS. Last video in a series of 4. The other 3 work fine. Clearly a youtube issue.

To be honest I’m not really relying on this but added here if it assists in helping the original poster.

Thank you for all the responses and useful input. I didn’t provide the URL because I’m haven’t published yet, I’m just experimenting with the files on my own hard drive.

You were all collectively right. There is some kind of problem with YouTube and that specific video. When I used a different video the page worked as expected.

As a newbie you always expect that when something goes wrong it’s due to something you did. I never expected a problem on YouTube’s end. Come on YouTube, lift your game!

Thanks again for the help.



Following up in case someone searches for a solution:

If you have an outstanding copyright claim on YouTube, your link to the YouTube video with the claim will not load using the Video Embed stack.

Once my copyright claims were resolved the links worked as they were supposed to.