Video seems to work in Vimeo but not with YouTube. Even the pre-loaded examples won't load for me

I get the error “video unavailable.” I also tried using one of my own YouTube videos by copying the “YouTube ID” which I guess is the part in the URL after the equals sign? That didn’t work either. The only thing the stack is inside of is a container. I know I usually need to send the file but I thought I would ask first since it seemed so straight forward.

Sounds strange. Since you didn’t give details, I have to assume you’re referring to the Video Embed stack. It seems to be working here for me with no problems.

I even loaded up the documentation page in Safari v15 to make sure it worked there and it also seems to be working OK. You’ll need to provide more details and a project file please. If you do that I can look at it sometime tomorrow, or perhaps someone else will beat me to it.

If I remember correctly I get that result if I preview the page, but all works fine when page is published

1 Like

Turns out that was it. The page with the YouTube link just needed to be uploaded first before clicking it. The only issue so far that I can see is that the part of the clip I want to show comes on about 20 seconds early. The video is of a movie review I did and it starts at the very end of someone else’s review now. That isn’t too bad since it’s pretty close but it would be nice if I could get the exact time.

I still need to add a thumbnail but I was wondering if there an option with the Video Zoom stack to use the default thumbnail that they already used on YouTube? I like the still they used and it seems like that is an option that people would commonly pick.

Here is the link to my page with the video on it. You need to scroll to the bottom to get to it.

@Kip I don’t think you can put in exact times for a video. You need to start at the beginning. This is for both video stacks you reference. If you need it to start at the exact time then it’s better to (1) edit/change the video or (2) use the link YouTube provides you with the exact time and then just use it (many options) without these 2 stacks. There’s a third option, tell folks to wait 20 seconds until the “exciting stuff” begins. :slight_smile:

As for default thumbnail there’s no default way to do this as you want. But it’s easy enough: take a screenshot of the frame you want, reduce in size if you want via something like TinyPNG, and add as the image where you are asked to insert an image in the stack.

Again, this is strange to me. As seen in the video I linked to in my above post I preview the video directly in RapidWeaver without ever having published the page. Can someone provide me a test project file that shows this problem of the video not playing in RapidWeaver’s Preview Mode? This would be helpful.

Both the Video Embed and the Video Zoom stacks allow you to set a start time for YouTube videos. This is shown below and outlined in the documentation for both Video Embed and Video Zoom.

CleanShot 2021-09-29 at 07.07.32@2x

CleanShot 2021-09-29 at 07.07.17@2x

The thumbnail seen in Video Zoom is not directly related to the video itself, and thus has no way of pulling that thumbnail from the video. The Video Zoom thumbnail is simply a linked image that is set to trigger a lightbox containing your video embed from YouTube or Vimeo.

I notice @Kip mentioning Video Zoom above. Is this where you’re seeing the problem? If so, the default YouTube video for that stack needs to be updated. YouTube stopped allowing you to embed some copyrighted material, and that default video is a good example of such a copyrighted video.

I’m about to leave for airport. Sorry re: starting times capability: my bad

Yes, when I’ve seen video not available in Preview they were likely all commercial videos

I’m going on memory while doing final packing so may be wrong on some details re preview

1 Like

Have a safe flight. :airplane:

No problem. You likely didn’t notice it as you use mainly Vimeo videos, and that isn’t a feature in the stack for Vimeo embeds.

Good to know. I’ll keep an eye out on this thread in the event there’s more info for me to go on.

Yes, I am using Video Zoom and it doesn’t play YouTube in RW preview or locally in the web browser. It only works once I put it online. I don’t know if it has to do with copyright since the video file does ultimately play once it gets online. I didn’t test the default video online, I don’t think. The video I am referring to is the one that plays on this webpage (at the bottom) not the Imagine Dragons music video that is used as the default video. It is just a little production from my local video store:

The issue right now is mostly getting the video to start at the right time. I am guessing if it comes on 20 seconds early I can probably set it for 20 seconds later as a work around although but that is a strange way to do it.

I may just take a screenshot of the their YouTube thumbnail to use but maybe it needs something that is higher resolution. I can send you the project file in a bit.

Try this YouTube video ID: 3hf30Sf-ddA

Does it play in Preview Mode for you?

As for your video (YouTube ID: 8CGo_D8Rtnw) – I suspect this is due to the content and / or settings on your video. That is not something I have any control over.

The video ID I shared above (3hf30Sf-ddA) is free of copyrighted material, and is set to be public. You can see my settings here, but of course this doesn’t take into account the content of the video.

As I said above, there is a setting for this in the stack. Please refer to the documentation.

By the way, you’re inserting the entire URL into the ID field, as seen below, which is incorrect:

CleanShot 2021-09-29 at 14.23.19@2x

You’re only supposed to insert the ID. This is covered in the tutorial video, so be sure to give that a watch.

I’ve tried a normal embed straight from YouTube and it returns the same message. I suspect that the video is setup to disallow embedding (or YouTube has flagged it to disallow embedding based on copyrighted sounds, music, visuals, etc). Just my guess. Or perhaps set to only allow embedding on specific URLs? I can’t remember if YouTube has this feature or not.

Yes that video plays.

Okay, I am not sure what the settings are for that video as it is someone else’s video. That is likely the problem.

Alright, I’ll just have to do the math to convert minutes into seconds. That’s fine.

I tried to just copy and paste the ID info but that’s wasn’t working until I posted it online. Now that I know you need to post it online first for it to work I’m guessing the ID itself will also work when I post it online (and set the time using “start at:”. For a while I was just trying different things since I couldn’t figure out what was going on, and why only Vimeo was only working in the preview.

If it is not your video, you don’t have any control over how it is setup. You’d need to talk to the video owner. That is far outside the realm of this support topic though. That said, I looked it up, YouTube will allow you to restrict where a video can be embedded.

So, it looks like this is not a stack problem, but instead a content problem or restriction. If you’re good with that assessment, I will close the thread. If you think otherwise please let me know and we can discuss it further and look into it deeper. If you go that route I will need you to create and upload a video to YouTube as a test video for us to work with. That way we know the video settings and can adjust them since the video will then be one of your own and not someone else’s content.

In a ways the problem is on the YouTube side of things whether it be the way YouTube works or how someone sets up their video. On the stack side I think it would be helpful if at a minimum the tech notes told me about testing the video after publishing it and how that seems to get around the problem. If I knew about that in head of time I likely could have figured out the other problems. I think most of the other aspects are fairly straight-forward.

I think it may be helpful to keep the thread open while it is technically solved now. I’m guessing I can get it everything running 100% today but just want to make sure.

This was not a known thing until now, so I couldn’t have warned you of it.

You’ve marked it as solved, so it automatically closes itself 24 hours after the last reply.

Makes sense. I got the right part of the video to start now! Just had to enter 1834 seconds into “Start at” so I’m really glad that is up and running with the two people discussing my bit. I was tired last night and didn’t think about converting minutes to seconds. Now I’ll just add the thumbnail and a subhead that says it a collaboration with another video editor. Then it should be done.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.