Weird "phenomenon" with droplet tagging in Alloy

Hi everybody,

I have a weird “phenomenon” with Alloy Editor since I started working on my latest project. This isn’t my first project using Alloy, and I know how to set up and use Foundry and Alloy, yet I haven’t encountered this behaviour before.

There are two problems:


As you can see in the screenshot, the ‘tag’ field in the Alloy droplet overview shows the content of the droplet instead of the tag. So when clicking the “copy” button, one copies the content and not the tag. Droplets containing images will display the URL to the uploaded image here.

Furthermore, when I manually enter the tag on a page, the droplet isn’t injected. Instead, the visitor sees the droplet tag.

I’ve tried all I can think of:

  • created a new page with a new instance of Editor within the existing project
  • specified other folders to store the droplets (and embeds and image-uploads)
  • started a new project with a fresh instance of Editor on a newly created page.

All to no avail I’m afraid.

For some reason, the behaviour is now standard. Even when I create a new project file, the Alloy Editor displays this behaviour “out of the box”, wven before I get a chance to mess up anything on the page.

I don’t dare to upload any changes to my existing sites (that work fine for the moment), fearing that they too will break.

What am I doing wrong?

I hope someone can help!

Here’s everything to see it in action for yourself:

Project file: (2.5 MB)

Live URL:

Alloy log in for live URL : user password: test123

(No worries, this live URL is to demonstrate this issue only)

Cheers and thanks in advance,


What is the URL for your Editor page?

Whoops, sorry:

Thanks. Additionally your ZIP file is not the project file, but the exported site.

Provide us a copy of your project file please.

Create a ZIP file containing your project file. This is the file you open in RapidWeaver to edit your site. After creating the ZIP file, upload it using a service like Dropbox, WeTransfer, Droplr, or a similar service to create download link for us. Paste that download link in your reply.

Hi Adam,

You’re right; sorry.

Here’s the project file: (804.2 KB)


Please try removing the Droplets stack from the Editor page. It should not be there. Basically you’re having the Droplets stack replace the tags in the Editor!

After doing so republish all files from RW.

1 Like

Oh no! I’m an idiot…!

Remember I said:

This isn’t my first project using Alloy, and I know how to set up and use Foundry and Alloy

I take that last bit back :wink:

Thanks Adam, this solved it!



Glad that got it sorted for you. You created a loop essentially. You’d create a droplet, and as it saved it would replace the tags with the data you’d saved. :exploding_head: :exploding_head: :exploding_head:

Then on the Droplets summary view it would go through and replace the tag in the copy field with the data in the droplet files, and around and around you’d go. :laughing:


I understand… pretty logical when I think about it. For some reason I added the parser to the Editor page on all tries. It must be the drought… :slight_smile:

Thanks again!


1 Like

No worries. Just glad we got it sorted for you.


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.