Why does card deck stack get really narrow with certain orientations?

While running a simulation on different devices I noticed that this card deck stack gets extremely narrow when in either mobile landscape or iPad Portrait. Rather then list all the settings I thought it would be best to just include the RW file. This issue happens on the same page I mention here. I am actually not sure what stack is causing the problem so I thought it would be better to just upload the file that is listed in the original post of that link.

To get to this sidebar you click on the first white button which is right below that set of blue buttons. This is one of the last pages I need to complete to get this site going so I will be really happy to get it uploaded after five months! It has been a busy Summer.

Card Decks do not break to a new line. They’re likely getting as narrow as they are in your example because of the way you’ve built your page. As always, we have no way to diagnose anything from a screenshot. Provide the project file or an example project file that recreates the problem if you wish to get assistance with things. Otherwise the only advice I can provide is that you re-examine your page layout.

The project file that has these narrow cards is the exact same page I uploaded two days ago. Here is the link to the project again: iCloud

I am just showing you screen shots as well since some orientations look perfectly fine so you may not realize the problem until you look at a very specific simulation. I should also mention this one area is the only section in the side slide that is doing this. There is quite a bit of content above this and its fine across all devices and orientations.

The side slide opens with the button that is near the top 20% of page that starts “While Joan…” once that opens it is at the bottom of the side slide. I hope I explained it better this time.


Re-check your design. You’ve got your Card Desk inside of Flux. If I temporarily remove it from Flux it looks like expected. This means your settings for Flux are causing the excessive “gap” you’re seeing. I did not step through all of your settings, I’ll leave that to you, but this should give you a starting place to look.

I noticed the flux stack that was there before I sent the file. At first I thought that might be the problem so I took it out the Flux stack and checked it again the simulation was still giving me the same results. When I took it out of the Flux stack this morning it worked. Sometimes I wonder if simulation always picks up the changes? I’ll click the reload button to make extra sure it becomes aware of the new settings. Have you had experience where simulation doesn’t work right away?

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.