Alloy - Enabling RSS Feed Results in Blank (Empty) blog/ Page

Running PHP 7.3
Markdown posts display correctly until RSS Feed enabled at which point an empty page is returned. No XML file generated.

Did wonder if it was the parsing of a post that somehow caused the problem but the same still occurs with no posts.

Anything obvious/likely that I should be looking for?

Hi there @Unintended_Consequences and welcome to the forum!

First thing I’m going to suggest is the standard “turn it off and back on again” solution – in other words: In RapidWeaver do a Republish All Files. Once done, clear your browser cache and then revisit the page again. If you’re still having problems though… It will be infinitely easier to help out if I can get a few things from you for testing. If you can send me the following in a ZIP file it will help me out greatly!

  • A copy of your Posts folder that contains your blog posts.
  • A copy of your project file. This is the file that you open when editing your site in RapidWeaver.

Also helpful would be a link to the live page where you’re experiencing the problem.

Hi there @elixirgraphics - I’ve turned it on and off, cleared the caches and re-published all files to no avail.
One of the experiments I’ve also done is to remove my posts and add a couple from the Alloy / Sample Posts folder but there’s no difference. I’d have thought it unlikely therefore that it’s one or more errant posts causing the problem.

Have created the zip file - presumably not to be posted on the forum?

You can send it as a DM on the forum or to my email address: adam at elixirgraphics dot com

Also, do you know what type of line returns your text editor uses? Are they carriage returns (CR) or line feeds (LF)?

All done (by email … and we have to get to 25 characters it seems …!)

Off the top of my head - no idea. Mixture of TextEdit, Sublime Text + Marked 2, Multimarkdown Composer

That’s a lot to troubleshoot. Can you try making a new post using just OS X’s TextEdit for me when you have time. Off to have lunch, but should be back in to the desk in an hour or so.

I didn’t see a live URL in the email you sent. What is the live site URL?

Starting my testing… I published a project file of my own, with RSS feed functionality enabled, and replaced my posts folder with yours. Everything works as it should. If I publish your project file, with the RSS feed enabled I too get the blank page you’re seeing as well. So I think we can so far eliminate the posts and possibly Alloy as the problem. Let me investigate and get back to you.

Also, it you have a PHP log file on your server that shows your error logs that would be helpful to have as well.

Got it. You’re using double quotes in your RSS feed description. Alloy uses double-quotes for its PHP in this section of the code, so your double quotes are interrupting it. Best to go without quotes there anyway, IMO. Remove the quotes from around the phrase "the whole" in your RSS feed Description field, then do a quick Republish All Files and you should be good to go.

1 Like

Yes - it was the quotes in the description. It would help, however, to have some means to escape these sorts of things.

ANyway, back in business - thanks!

You can do that if you really have to have those quotes by using PHP escapes.

Just put a \ before each of the quote marks. That should do it. I’m no next-level-RSS-ninja, so I can’t tell you whether these quotes will cause you problems in your feed. For me, always – simpler is better.

Thanks. Yes the \" works. It’s not really an edge case though …

Not sure what you mean here. Can you explain?

I think something along „not critical“ or „not too important“ regarding the quotes…