Alloy images not showing up on Mobile

Hello, images inserted into an Alloy post are showing up on desktop on all window sizes in all browswers just fine. But they are not showing up on iOS Firefox or Chrome. They are however showing up on iOS Safari. Would you now how to fix this?

Live site:

Just loaded up you URL in iOS Chrome and all is well it seems.

It’s still not working for me. I just installed Brave and still nothing. removed VPNs. Tried cellular only. Tried private windows. Deleted cache. I am also experiencing the same issue on my 12.9" iPad Pro. I am on iOS 16.6.

i just asked another friend to check and the photos arent showing up for them either.

i figured it out tho, my SSL certificate is on and not and Alloy drops in www. automatically so the images were not covered and being insecure. soon as i removed www. in the image SRC url it worked.

Thanks again

1 Like

Alloy uses the URL you’ve provided in your General and Publishing settings.

Mine didn’t. I specifically excluded www in my web address in my projects general settings but it still added www when dropping in images in Alloy. That’s why I had this issue in the first place.

Btw, do you have a link you can share where I can see all the mark down and HTML Alloy posts support so that I can understand how better to customize my posts. Like can I add inline CSS to style the boarder of a dropped in image. Better yet is it possible to to create CSS classes somewhere that I can use in each post?


Alloy uses basic Markdown. Nothing fancy beyond the bare necessities.

You can add any HTML you like to Markdown. You’d put your custom CSS in the Custom CSS field within RapidWeaver though. Cleaner that way.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.