Alloy- Images not showing

Hi,
Oh dear. I seem to have got by over the years without asking many questions but regret I have to now.

Bought Alloy as soon as it came out but have not implemented until now. To test I did not put Alloy into an existing division of my website but created a new project. Created new entry with a link to an image file which I see is in the image-uploads folder with its thumb. But the image is not showing in preview. Have read the previous questions regarding this but not been able to solve it.

https://www.christleton.org.uk/christleton5/blog/

If Adam does want to see my project a short note on how to send it would be welcome.

Thanks,

Richard

Screenshot 2022-03-09 at 11.59.55

Have you followed along with the Quick Start videos and replicated everything seen in the videos? These videos should get you up and running.

If not, please do so. If you have, then I’d suggest making sure your Publishing and General Settings URLs for your site are configured properly. To be honest I suspect this is your problem. After correcting it, go into your post, delete the topper image and upload a new one so that Alloy can generate the URL correctly based on the corrected URLs in your project file.

Have done set up a few times but no luck. Might have nothing to do with it but I noticed that the edit button on the editor page is not showing the graphic pencil and lines. Just shows a dot. Also the cogwheel is not showing but has a blank square that does link to embed etc. Graphic buttons on these other pages are ok.

Also noticed that when I click the add image button I get an exclamation mark plus pair of empty square brackets and then the url of the image in a pair of curved brackets.

^^^ Have you double checked this? ^^^

If you have, then please send me your project file as it stands now and I will take a look. If you have not then please do so.

After ensuring that your URLs are configured correctly… Provide me a copy of your project file please. Create a ZIP file containing your project file. This is the file you open in RapidWeaver to edit your site. After creating the ZIP file, upload it using a service like Dropbox, WeTransfer, Droplr, or a similar service to create download link for us. Paste that download link in your reply.

Hi Richard, when I first started using Alloy the images weren’t showing as well. It turned out I named the folders in my RW project something like “/homepage”. I started the names with a slash, an old habit. Once I renamed the folders to “homepage”, and thus deleted the slash, everything worked just fine.
It’s in Adam’s manuals but I overlooked this.

Just an idea,

Hans

1 Like

Hi Hans, Thanks for your interest. I did read most of the previous messages about lack of images and remember seeing yours. No I have not made that error. I am busy preparing a project file for Adam to kindly look at. I was surprised that it did not work as the videos were a good guide as to how to set up. and it looked straightforward. So will be very interested to see what Adam may find and hear his guidance.

Richard

Hi Adam,
Had a few more attempts but still no images. Have made a simple project file with just one entry with an image url.

Link to the file is Dropbox - Blogtest.rw8.zip - Simplify your life

Richard

The URL you provided leads to a 404 error page. Must be something wrong with the link or maybe an issue on the server side.

Thanks Hans. Have not used Dropbox for yonks. Do I need to attach link to an email? but do not know Adam’s email unless it maybe adam@elixirgraphics.com

@oldmaps

First problem with your project file is that you’re not using the Foundry theme. This is the cause of some of your problems like this:

This is expected. This is the way Markdown images work. You’re getting that because you clicked this button in the Editor:

The Image Upload button, found here (see below), will upload an image to the server and auto generate the Markdown Image link for you:

Each button has a tooltip for you, so if you hover over them you are told what they do:

As for the project file you sent over. That project doesn’t match what your website shows. So I’m not really troubleshooting your problem directly. That said, I’ve published that exact project file to my server, and you can check it out.

The blog is here: Blog | Blog Test

The Editor is here: The blog is here: Editor | Blog Test
The credentials for login are: admin / password

You can login and give it a try it out for yourself. I’ve uploaded an image as the topper as well as one in the body of the default sample post.

You’ve uploaded this project to your server and it does not work?

If you’ve only uploaded your other project, that you did not provide, then provide that for us. We can’t troubleshoot what we don’t have unfortunately.

He was referring to the link to your blog. It no longer works.

1 Like

I’ve deleted your last post. I have the download, as seen from my reply above. The broken link, as I’ve stated above is that to your blog.

Thank you Adam. How could have I been so stupid. I am not going to blame my age as I will only be 80 in July. I think it was sheer excitement in starting to use Alloy after it had been in its box for so long.

I am all Foundry now but the Master Style is still set to another big Rapidweaver world I once lived in.

Thank you so much for your fast reply.

Richard

1 Like

That solved all your problems then?

Sorry not yet. Rebuilt a new project. I think it has something to do with the image link. In the link to Blog Test you gave me I can see your seascape photo but that is not appearing in my rebuilt blog when I use the browser, I just see the text entry. I do not see this photo it editor either. Also when making the link to an image in editor I see ![] (that’s exclamation plus 2 square brackets) before the url

I don’t understand most of what you’re talking about unfortunately. As for this:

That is for your alt tag. It is supposed to be there. Please google Markdown Image.

You can see it here in my test blog using the project file you sent me:

Blog project has progressed from yesterday and now have a blog that is useable. Probably the one thing I have not cracked yet is the addition of a Topper image. Click on this, choose image file and get a red dot with cross in the middle and on the posts list a broken thumbnail image logo. But the blog is quite useable as it so will probably introduce it to one of my sites in the next day. I am continuing to look at more videos on the additional features.

Send me a DM with a link to your Editor page as well as login credentials please.

All resolved thanks to Adam. I now have a fully working Alloy Blog. The solution was that my test blog was inside a fold named testblog and therefore my Editor page was not a top level page. Once I started using my old blog folder on the top level everything went into top gear. Very pleased with the change.