Blog edit look doesn't match published look

I write out blogs, format the sentences and paragraphs the way I want to but it never publishes how it looks in the blog editor.
Here’s how I type it out and format it…

But it looks like this after publishing…

Is there a setting I’m missing?


Hi, I’m a newbie here but I think it’s Markdown syntax problem. Pressing the return key once is ignored in Markdown context, you have to hit twice or put two blank space (hit twice spacebar) at the end of sentence to create a new paragraph. Hope that help.


Thanks Bruno. I guess what’s throwing me off is the fact that the ‘Preview’ doesn’t show exactly what the finished/published post will actually look like.

at the end of each line where you want a line break, it the line is quite short.

Thanks. Will try that. @elixirgraphics is there a way to get the preview function to work better?

The preview works as it is supposed to. I am sorry that you don’t prefer the way it works, but it works properly as-is. I will take your notes if and when a major overhaul to the editor occurs.

Thanks Adam.
Is there maybe a setting in RW (Alloy stack) that maybe I need to check out?
Seems like the Preview isn’t showing me exactly how it’s gonna look when published.
Here’s a test blog I put together. Notice it doesn’t look any different from when creating it to the preview.
But after publishing, it looks different.

It isn’t an exact preview. The editor uses a slightly different rendering engine. The editors main code is used from a library to save me having to write it completely from scratch from the ground up and not reinvent the wheel so to speak.

Since you now know markdown requires an empty line between paragraphs you should be good to go now though. :+1::+1:

1 Like