Blog entries not displayed, at all, despite following guides

Hi Adam,
I installed Alloy 3.3.2 staks in a new project (Foundry 2), step by step, as your video guides: editor (not as home page), credentials, than, blog; identically as you presented. At the end, it cannot display the blog entries, at all.
Surprisingly, I have a similar project hosted at the same hosting company, within the same hosting space, which works fine (PHP 7.4).
I used RW Classic in this project configured with PHP 7.4, as well.
Please let me know what’s happening! It becomes very frustrating and time consuming.
Shall I send you the project and the zip archive of the site to see what errors are generated?
Thank you very much for your support!

Hi there @lucian0209

Sorry to hear you’re having trouble. Yes, a ZIP file containing your project file (this is the file you open in RapidWeaver to edit your site), along with the published site (including the Posts and Images folders) would be helpful. As would your PHP error log file.

Create a ZIP file containing these things. After creating the ZIP file, upload it using a service like Dropbox, WeTransfer, Droplr, or a similar service to create download link for us. Paste that download link in your reply.

I can take a look at this first thing tomorrow when I’m back in the office.

Perfect! See the link below.
Best regards,

@lucian0209 – Don’t forget to send your PHP error log file as well.

Where can I find it? I thought it is within the site archive.

That varies depending on your host. You’ll need to consult your host’s documentation.

First thing I notice is that you have special characters in your user name for your Editor credentials. You cannot have special characters in your user name, as is stated in the settings directly below the field:

CleanShot 2023-07-17 at 17.49.47@2x

I don’t know that this is causing you trouble on your server or not without your PHP error log file.

That said I uploaded your site, along with your test post, to my server and all seems to be working well here. You can visit the blog here and the editor here. I setup temporary credentials for myself, but you can try using the credentials you created for yourself as I left them as well.

The blog seems to be displaying fine, and the editor is working as expected.

I’m off to make dinner, but if you provide that error log file I can look at it and see what might be going on. That said it doesn’t look to be Alloy itself at this point.

I am really shocked to see that is working in other environment.
Anyway, I generated the PHP error log with Alloy control center: (963 Bytes)

Reading the log on my phone so forgive me for the short reply. Looks like your host does not have mb_strlen function enabled in your PHP settings. You may need to contact your host to have them install this for you.

I asked them to activate it, and they replayed that they activated mbstring, instead, saying that mb_strlen should be within. It seems they are not familiar with mb_strlen :wink: What else shall I ask them? It still doesn’t work :frowning:

They are correct, mb_strlen is a function in the mbstring package. You likely have an additional problem. PHP stops executing when it hits an error. So any other errors after that will not be known until you’ve fixed the first. You’ll want to delete your current error log file, then revisit the problem page. This will create an updated log file with the current problem. Again, I suspect it will be a server configuration issue.

It was not working because they lied to me that they enabled it, but they didn’t. After I insisted to look deeper, they finnaly did it, and now it works perfect. As always, you were right :slight_smile:
Thank you very much for your quick support!!! :blush:
Best regards,

I’m sure they didn’t lie. It was probably just a miscommunication. They really have no reason to lie to you. They want happy customers just like I do.