Bug when using override font

Hi Adam,
When I’m in edit mode, working on a project and my page has a bunch of stacks - enough to have to scroll up and down the page to work on different stacks, let’s say I have a page header stack in there and I change that page header to use override font, everytime I finish with an edit in edit mode the page pops up to the top of the page and I have to scroll back down to where I was working. No matter what stack I’m working on or what change I make, it will pop back up to the top of the page and I will have to scroll back to where I was working - obviously very annoying in terms of work flow. At first I couldn’t figure out what was causing this, so I did a series of edits and then a series of undos and realized the culprit was checking the override font box.
It really makes it very difficult to work like that. Can you look into this? If you need more explanation, let me know.

@adamk – This sounds like a Stacks plugin bug that is being kicked off by something in the project, like the override checkbox or something else. If you could send me your project file that would be helpful. Email it over to adam at elixirgraphics dot com

I’m headed out of the office right now, but will have a look first thing tomorrow.

I’m having this issue as well. Just the foundry stacks on the page.

@Steve_J: Shoot me over a project file with the problem and I’ll take a look. :+1:

Same stack involved by the way?

It could be any stack, not just the same stack And I don’t think it’s just the override font, the override font seems to be one thing that triggers it - but I think it’s a much bigger problem then that.

@adamk: Ok. ZIP up your project file and send it over and I’ll take a look. :+1:

Great. I sent file. Thanks.

Hey there @adamk – I’m not seeing it in my inbox anywhere. It may not have gone through if it is a large file. If that is the case a service like Dropbox will need to be used to send the file.

It sent according to my email. It’s not a large file. I’ll try and send again. I’m just sending by replying to the email you sent me.

@adamk – I don’t remember emailing you previously. Instead of replying to an email just go ahead and send to adam at elixirgraphics dot com


Okay, I sent again. I guess it was the email I got from discourse that I replied to - my bad.

Just got them. Thanks. Will take a deeper look tomorrow. First thing I noticed though was the mis-spelling of Roboto in your Control Center stack for your Base Font:

Be sure to replace robato with Roboto there. The same goes for Lato in your Page Header stack. It should be Lato as where you have lato. Unfortunately Google fonts are very specific. That’s why I tend to copy and paste them instead of typing them because I know I’m prone to do stuff like that, too.

Let me know if that fixes your problem. If not I can take a deeper look in the morning when I’m in the office.

That seems to have fixed it - that’s why you get paid to make Rapidweaver themes, and I don’t.
I will test it a bit more and see if anything else makes it behave that way, but problem solved for now.
Thank you so much!
Adam K

1 Like

Glad to help! Happy the fix was just that easy. Now to look into @Steve_J’s project file when I get into the office.