Can a RapidMaps 3 plugin page be incorporated on a Foundry Stacks page?

Hi all - Can a RapidMaps 3 plugin page be incorporated on a Foundry Stacks page? I’ve created a Map with Rapidmaps that is very functional for my business that offers services from about 30 locations - this map is the first I’ve found that does what I want, but I can’t work out how to build it into my site. Thanks for helping, if you’re able :slight_smile:

@fitnesskey Does this plugin come with a Stack that you can use to import a map into?

1 Like

No - incredibly disappointing that it doesn’t - I’ve even found reference in the comments section where I purchased it, with the developed promising that there will definitely be a stack coming “this year”… that was last year. I’ve purchased for nothing - again - I have to stop doing this. Oh well. Thanks for your answer - I appreciate it.

Here is a new stack from Wil that might fit your needs. He stands by his product like Adam. Locator | Stacks4Stacks


HOLY SHIT-BALLS, BATMAN!!! Steve! Steve! … and also Wil! That map stack brought a tear to my eye! It’s absolutely beautiful! It’s beautiful and its mine all mine! THANK YOU!!! SOLVED! Will post its integration on my site here when it’s up and if it’s a quarter as cool as it looks to be, I’ll be a very happy camper indeed.


Hi again Steve… any chance you’ve used Locator? I purchased, followed the prompts and education and edited the .xml file he suggests I do… I can test load HIS unedited .xml file and it loads instantly and functions correctly… when I load mine - nothing but a white screen. I’ve spent a few hours now, troubleshooting, and I KNOW that my file is simply my map data loaded into HIS template file and is in every way identical except for the info inside - but mine doesn’t work. I’m stabbing in the dark here but is there a chance there is a location number limit? I’ve loaded 28 locations… MY file works with the first several if I test as I build it, but when I thought to myself “all good Steve - you’ve worked this out - go ahead and complete the file for final upload”, my now full file does not work. I know it’s a long shot reaching out here, but thought I’d try as I’ve had no fast answer from the developer. Cheers.

Wait! scrap that request! I just became an accidental coding superstar - I trialled and error’ed my way to victory by deleting locations one at a time, re-adding them, testing each time… found the one out of the 28 that was causing it to white screen on me… then sat and thought and looked and decided that the single ‘&’ symbol used there, was the only & I had attempted to use… sure enough… replacing it with ‘and’ miraculously fixed the problem. Yep! I did that! I did that and I have now returned to the same level of excitement about my new map as I originally enjoyed. Yay! I’ll post a link to show it off soon. Thanks again for the help earlier with finding this confusing but awesome stack.


@Steve_J - you’re a superstar recommending that stack mate… works a treat. There is some improvements needed which might come in V2 as I’ve had extensive chats with Will and I’m still in the process of ironing out some issues… but its working pretty well here… - cheers. The stack is pretty resource heavy unfortunately and for example if integrated on the same page as a datesnap calendar - see my appointments page - there’s just not enough speed to use it… page load is abominable… Will suggested it is used separately hence my appointments and locations page ending up seperate. Not sure how useful it will be, but its a solution I’m using now. Ta :slight_smile:

1 Like