Can't upload topper images

I’m stumped. I can’t upload topper images. The new version of Alloy looks great, but if I can just get that one thing working …

I checked other threads on the forum. The editor folder is where it should be. I made sure that my image filenames only have letters in them. I checked the images folder (which I’ve designated in Alloy as blogPix2020ff, and there is a corresponding folder on the server). I don’t know what else to try. Any suggestions? Thanks in advance.

Have you made sure your file paths are correct in the General and Publishing settings of RW?

I’m just going to have to keep trying things, I guess. You know how it can go: something doesn’t work and you don’t know why. You keep hammering away at it, then eventually it starts working and you don’t know why.

I have the blog posts in a folder named blogPosts, but I found in the General Settings / Metadata of Alloy that it was listed as something else. I changed it to blogPosts and somehow created a regression. Now the summary view lists blog posts dated 1-1-1970 that don’t exist. Screenshot attached.

I’ll need some thing to troubleshoot your problem. Send me a ZIP file containing your project file. I’ll also need a link to your live page as well. If I have those I will have a better chance of diagnosing your problem instead of just taking shots in the dark.

I cannot promise I’ll look at it today as it is Thanksgiving here in the US today, but I will take a look as soon as possible.if I have your stuff on hand and I have the opportunity I at least have the option of looking at it today if I get the chance.

Also when you send that stuff over can you show me a screenshot of what is in your posts folder on your server?

Thank you, Adam. I will do that. In the meantime, I’m going to try deleting the blog entries stack and just setting it up again. When I first upgraded to v3, I found that the blog entries stack was labeled simply “blogs,” which makes me think it was left over from v1 when I started using Alloy. Maybe a totally fresh start will correct the problem on its own.

Off-topic: What impresses me even more than Alloy is the effort you put into supporting your customers. I just quit another product (which shall remain nameless) because although I had no complaints about the product, the tech support was so astonishingly stupid that it made me lose confidence in the product itself. Your support gives me the opposite feeling about Alloy. Thanks.

1 Like

The Blog Entries stack has never been called simply blogs. So that seems odd. Did you make sure to restart RW after updating?

Let me know how rebuilding it goes. I’m still happy to look at it for you as well.

Thanks! Appreciate that!

Off to go join a Zoom call with family.

Fortunately, we had our Thanksgiving two weeks ago because of family schedule conflicts. So I am working today.

I’ve now built a blog page and editor page from scratch on a test site, using exactly the same steps as you did in your videos. Nothing more, nothing less. I’m encountering the same problem. Since the stack works okay for everyone else, it must be something specific about my setup. So I started trying to rule things out.

I tried a different browser (was Safari, then tried Firefox). No joy. I tried fiddling with the firewall settings in my big-name security program. Nope. I tried switching to a Windows PC that has a different big-name security program from a different vendor, opened the editor in Firefox, and still had the same problem.

So the problem is not the browser, the security program, or the Rapidweaver project that I created from scratch by following your steps. The only other thing that I’ve thought of is that it might be the web host, which is Little Oak. I’ve been pretty satisfied with them, they know Rapidweaver, and they’ve got good support. But the problem I’ve got isn’t exactly a Rapidweaver problem: it takes place if I try to upload an image from a browser page to the server. That makes me wonder if it’s some security setting on Little Oak’s site. Their tech support is open today, but heck, it’s Thanksgiving and I don’t have to get this done by 10am Friday morning. I’ll see if I can chat with them tomorrow and ask. We’ll see.

My thoughts would be to check…

  • Your PHP version to make sure you’re up to date. You likely are, but it can’t hurt.
  • Check to make sure you’re using Stacks v4.
  • Check to make sure your URLs are properly configured in the General and Publishing sections of RW.

Again, if you send me a ZIP file with your project as well as a live URLs for the Editor and Blog (and login for the Editor of course). I can look it over. But I do need all of that stuff.

Until I had tried everything myself, I didn’t want to take up your time looking at it. You already go above and beyond the call of duty. As for your latest suggestions: PHP: check. Stacks 4: check. URLs: BINGO!

I had a non-matching URL in the General Settings. Once I fixed that and a couple other things, I was able to upload images.

Thanks again for your help.

Awesome. Glad to hear you got it sorted out. :+1:

Thanks Noah and Adam.Similar issue for me with Topper images not uploading. Had not matched the General and Publishing website settings. Thought it was correct but forgot to change General setting when taking website live.
Sorry Adam, I sent a query to support before I found these Forum pages. Great resource by the way.

Glad to hear you got it all sorted. :+1:

Experiencing this issue currently. My URLs are good in both General and Publishing.
php version 7.3.33
stacks is version 4

Was working fine but since switching hosts from machighway to chillidog, the topper images don’t show.
They’re uploading (folder is ‘image-uploads’) as I see them using my FTP client.
Can I send a zip file?
site is

The URL is being generated for and not which is where your site is currently residing.

<div class="topper-single-summary-img" style="background: url( center no-repeat;"></div>

This indicates to me that the URLs are not correctly configured in your project file for the location.


And you’ve tried re-uploading the image for the topper again after setting the URLs to the correct location? If not please do so. The URLs for the image paths are created in the Markdown file when you upload the image and do not change until you upload a new image.

If you really do want me to test it on my server I will, but I am 99% sure it will work for me as I’ll be setting the URLs properly from the start so whatever images I upload will have the proper paths created during the upload of the topper image(s).

Got it! Republished everything and it’s working.
Thank you much

1 Like