Cinema no longer has fluid height!

On my homepage, the hero Banner has a Cinema stack set to fluid height, and it would always fill the browser top to bottom, cutting off the sides of the movie according to the configuration of the browser window. Suddenly there must have been an update and it is broken — the movie shows in the original aspect ratio regardless, and this ruins the intended appearance. Help!! How do I get it back the way it was before??

Update: this may only be affecting Safari (16.3 desktop) and RW preview itself. Other browsers seem unaffected.

Please specific what Foundry version you’re using and provide a project file, along with the movie file, for me to test.

Create a ZIP file containing your project file and the movie file. The project file is the file you open in RapidWeaver to edit your site. After creating the ZIP file, upload it using a service like Dropbox, WeTransfer, Droplr, or a similar service to create download link for us. Paste that download link in your reply.

I did do this but haven’t heard back. Was the file too big? Maybe I should create a duplicate fie with just the affected page…

Hi @Jeggler – I didn’t see a reply in this thread above with your download link. Did you follow the directions that I posted above.

Sorry, I sent the link in a reply to the email notification rather than putting it here — my bad! Dropbox - - Simplify your life

No problem.

You have Cinema set to Fluid height. This means it adjusts itself according to the space taken up by the content within it.

Cinema in Foundry 2 does not offer an option to match the height of the browser window. You may be thinking of the Banner tool in Foundry 2 that does this.

Strangely though it always used to work (ie fitting to the browser height rather than the media height), right up till a couple of weeks ago, and as far as I can see still does so in browsers other than Safari desktop.

It just seems like it does because of your content’s height within Cinema. If you watch this video of your site in Chrome you’ll see what I mean:

It simply adjusts to the height of the content inside. You have a good deal of margin being applied inside the Cinema tool in various places that helps it to seem like it is full browser height, but it does not match the height of the browser.

Yes, that is how it used to behave in Safari as well, and was exactly what I was happy to see. I don’t know what has changed to produce the current behaviour but I am glad Safari is the only browser affected.

I gather from your explanation that I am only seeing this browser height video banner as a kind of fluke. Do you have any suggestions as to what I should be doing in order to have hero video banners playing to the browser height intentionally?

This is what I see in Safari –

Looks the same to me at first glance as to what I see in Chrome. You’ve looked at it more than me of course. If you tell me what OS and Safari version you’re using I can look at it there. That said, nothing has changed in Foundry 2’s Cinema tool in quite a while.

Wow, that is very different from what I am seeing. Please have a look: Dropbox - - Simplify your life
This is what I see in Safari 16.3 under MacOS 13.2.1 and also in RW Preview. You can see that when the browser gets really narrow, the thing goes quite wrong. Hopefully not too many people do that.

That is odd. Looks ok in Safari 16.2 here on my macOS Ventura machine. Any chance you’re running any extensions or anything in Safari?

I had two or three extensions running, so switched them off and relaunched Safari. Made no difference. I notice I am using 16.3 and you mentioned you have 16.2. I’m not beta testing. I assume 16.3 is the latest version and not pre-release software, and maybe that is what has caused this to happen…?

I’ll update to 13.2.x and v16.3. Will take me a bit. That said, if that is the issue then it is a bug with Safari as Cinema uses a pretty standard setup for something like this.

Just got the OS and Safari updated to 13.2.1 and 16.3 respectively. I too see the problem now on your site in that specific browser version. I’m not seeing it on my Cinema documentation page on the Foundry 2 documentation site. Can you do me a favor and instead of using Margin inside of Cinema, switch them all to padding. If that does not work then remove the Margin tools from the Cinema tool. This is an effort to track down your bug.

I removed the three instances of Margins from the Cinema stack, and the result, surprising to me, was that everything looked exactly the same. Certainly the letterbox was still there. What is even more surprising is that when I previewed the page in Chrome and Firefox, they now have the same problem as Safari, the problem I originally posted about!

Sorry I missed this when looking at your project – It looks like you also have a Vertical Center in there. It is setting a specific height, as it is designed to do. Also you have a Banner tool behind it all with specific fixed heights:

It’s a couple of years at least since I put all this together and it is the only web site I am actively developing at the moment, so all I can say is that at the time I must have been throwing everything I could at it to see what would finally give me the result I was expecting to see. Neither then nor now can I honestly say that this is the best way of doing it — it was all trial and error. For now, I have discovered that if I change the Cinema desktop setting from Fluid to height 1300, then everything seems to be OK. I think I’ll adopt this as a workaround. Would Foundry 3 give me a cleaner way of achieving what I am after?

Gah, spoke too soon. Doing that makes it behave properly in RW preview and also when selecting Safari in ‘Preview page with’ in RW. But when published it still gives the letterboxed version. I am perplexed.

Remove the banner tool.