Cinema stack on safari 17.2.1

A recent update to the Safari browser seems to have stopped the auto play function in Cinema stack - Foundry 3. Besides having users change their browser settings, does anyone have any ideas how we can enable the auto play mode again? Thanks.

I’m totally up to date on my OS and Safari updates I think an I only seem to have v17.1 of Safari. Are you using a beta perhaps?

I am on Safari 17.2.1. This is the latest. 17.3 is the Beta version. Please refer to: Safari Release Notes | Apple Developer Documentation

On this version I see the play icon appear on the live version of the Cinema Stack. I have tried to include an image of the Cinema Stack webpage to show you hat I see on Safari.

I have to go to Settings>Websites>AutoPlay and change the settings. Then clear the cache and re-open the Browser to see the auto play in action.

If Safari has implemented an override to prevent autoplay videos then I don’t think there’s much I can do about it. The autoplay videos were already using a few “hacks” to make themselves play automatically as it is, so I suspect Apple has just made it impossible unless the user opts in. I’ll take a look but I don’t have much hope for this one.

1 Like

Thanks for the information.

I got updated to Safari 17.2.1, loaded up a Cinema page, and by default it works here. I didn’t change any settings in Safari whatsoever. Am I the only one?

1 Like

That’s great to see. I am in transit at the moment and I am thinking it could be the wifi I am on. I’ll be back home tomorrow and re-download safari and give it a go.

1 Like

After digging around I found the culprit! If low power mode is set, safari will not autoplay videos. Once I set the low power mode to ‘never’ then the cinema stack plays as it should. Apologies if I created more work for you.

4 Likes

No problem whatsoever. Part of the job. Good sleuthing. :+1:

Since my last updates of Safari 17.5 the Cinema Video plays only once and does not loop any more, whereas looping still works fine on IOS and on other browsers (Firefox, Google Chrome, Opera). All Autoplay settings of Safari and power modes of macOS are set as described in this post. Does anybody has an idea what could be the reason and what I could do? Thank you for any help

Have you checked the suggestion by @fg8 from above?

Yes, in the settings the low power mode is to ‘never’, and autoplay videos is switched on in Safari. I didn’t make any changes to the project, so the reason for cinema playing only once the video, without looping it, must be something else?!?
By the way: I have the same issue on your documentation for cinema
https://foundry.elixirgraphics.com/documentation/cinema/#gsc.tab=0
It works fine on mobile, but not on my Macbook Pro Safari 17.5, here the video is played only once and then stops.

Sounds like something to do with the Safari update changing the way it works in that browser. I’m not available today, out of the office, but that would be my guess.

I would be very grateful if you could investigate this as soon as you are back in the office. Cinema just doesn’t play loops, but this problem is only on my Macbook, not on the iPhone, and not in other browsers, - here everything works fine. Perhaps interesting: I have also used Impact Stack by Joe Workman for comparison purposes in my project now, here the video plays in loop in all browsers and on all devices. But I don’t want to use it, it doesn’t give me the setting options I need, and I would prefer to design the project using only the Foundry 3 stacks.

I’m not seeing a difference in the <video> tag’s properties in Cinema vs Impact. Both use the same inline properties for autoplay, loop, muted and playsinline attributes.

Are you using an MP4, WebM or both for your video? Perhaps try using just and MP4 and see if that clears it up for you. Remember to do a Republish All Files after making the change so we know everything gets uploaded properly for testing purposes.

Thank you for your help, Adam. Yes, I used both MP4 and WebM in Cinema and have now deleted WebM. Using just MP4 solved the problem on my website!
On your Cinema-documentation there still the video doesn’t loop. Do you use both MP4 and WebM there as well?

The demo site uses both.

Safari would seem to be punishing those who aren’t using just MP4s when it comes to looping. :man_shrugging:

:pray: Well, as Mac users we will probably have to follow the guidelines, what else can we do… :wink:

Safari holds a very small share of the browser market last I checked. Apple should be conforming to standards. What would be their reason for preventing something that works on other standards compliant browsers, right?! Anyway, glad you have a solution for Safari users. I’ll mark the thread as solved.

Hi,
Apple is a very strange company. Since the last update I no longer have the links on my directories in the Finder sidebar. No matter how much I configure them, they don’t appear in the sidebar. Episode title: the return of the bug already seen and reviewed! So you and your video formats :rofl: