Email Not Arriving


I have tried using both the Form and FormPro stacks to create an email form and have it send email. It appears to be working but the email does not arrive on my email client (Apple Mail).

I am using a shared hosting account on BlueHost.
I have tried using smtp
I have it set to send using my email
I have checked junk email
I have also searched the forum and read the other responses and messages regarding this.

If I look at my bluehost webmail client (online email) the email message is there.


I am really not sure at this point what to do. I guess I have the option of not using the form stack at all and just post a normal email address for the user to click and bring up their email client to send from.

If you’re seeing the sent email in your inbox via webmail then the form is doing its job and sending the form contents via email. The form doesn’t have any control of things beyond that unfortunately.

Makes sense. Having you confirm what I already knew makes me question the remaining part of my process, the “custom email domain” service Apple offers on iCloud.

I have my email address for the website setup using the service from iCloud so as to make email services not send my emails to peoples’ junk email folders as often. People have written that BlueHost hosted email accounts are among the worst as it turns out.

I will see what I can discover and make notes in this post for anyone facing a similar issue.


Please let us know what you discover. I’ve had good luck with DreamHost if you end up in need of a new host.

I use a SMTP service called Postmark to ensure all my emails are delivered. Like Adam said Dreamhost is a great hosting company, I use Siteground and love it as well.

1 Like

Just a quick follow-up…

I have the issue corrected. For some reason I had a duplicated SPF record in my DNS settings. I worked with the folks at BlueHost and they got it resolved and now things seem to be working normally.


Awesome! Glad to hear you got it sorted without having to move hosts (that is always a pain!).

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.