**Fatal error** - Who can help

Hi all
I have been using Rapidweaver for many years and have always been happy with it.
Now I have created and published a blog with Alloy. In fact, it worked very easily. But suddenly Rapidweaver crashes and I get the following error message:

Fatal error : Uncaught Error: Call to undefined function curPageURL() in /private/var/folders/z8/7j2x0gsd5c99hgy1vf98907r0000gn/T/com.realmacsoftware.rapidweaver8/RapidWeaver/4929/document-0x7fdff42072e0/RWDocumentPagePreview/news/index.php:133 Stack trace: #0 /private/var/folders/z8/7j2x0gsd5c99hgy1vf98907r0000gn/T/AppTranslocation/E5D61D6A-59C7-44C6-BE47-FCA63AAA41E5/d/RapidWeaver 8.app/Contents/Resources/RWWebServerLaunch.php(175): include() #1 {main} thrown in /private/var/folders/z8/7j2x0gsd5c99hgy1vf98907r0000gn/T/com.realmacsoftware.rapidweaver8/RapidWeaver/4929/document-0x7fdff42072e0/RWDocumentPagePreview/news/index.php on line 133

After a restart of Rapidweaver the error message is now in the “Settings” under “Master Style”. Unfortunately I don’t understand a word of it.
Can anyone help me?

I am using version 8.5 (20821) - and have updated all stacks.

Many thanks to all who give me their time to look for a solution.

Just trying to troubleshoot here. Is the Foundry theme selected? Do you have the Foundry control stack and the Alloy stack on the blog page you’re trying to publish?

Hi Steve
Thanks for your help.

Yes! I do have the Foundry control stack integrated in the page and theme selected.

I can’t even delete the “Error Message” under “Master Style”.

Best wishes

I would also post this on the Realmac forums. And I’m sure @elixirgraphics may have some insight as well.

Good morning @Tzatziki — can you send me a copy of your project file so that I can have a look at it when I get into the office? You can send it to adam at elixirgraphics dot com

If it is larger than 4 or 5mb it is best to send it using Dropbox or a similar service.

This looks like a crash that is happening to the app itself. If so this might be something you need to address with Realmac Software’s support, but let’s take a look.

I just tried adding an undefined function to a php script and it got the same sort of error. So the error appears to be comming from php rather than anywhere else in that curPageURL is not a recognised function.

It will be helpful to have @Tzatziki’s project file in hand so I can see what is going on with it specifically, as curPageURL is a defined function within the main Alloy stack’s head-insert template.

@wirrah – did you test with RW 8.5 or a different version? If you tested with v8.5 would you mind testing real quick with v8.4?

Hi Adam
My project is on the way - with “wetransfer” …

Thanks so much for everything.

First problem I see is that you’ve nested your Editor page inside your News (blog) page. The Editor has to be a top level page. I believe this is something I cover in the tutorial videos.

As for the blog itself – it looks like your published site seems to be displaying the blog properly. I don’t suspect the Editor is working as it should, because of the problem I mentioned above, but since I don’t have a login I can’t test that.

As for the Master Style page in your settings – that I cannot explain. That seems to be a problem with RapidWeaver itself, and not something I have control over. I see the problem in RapidWeaver v8.5 but not in RapidWeaver v8.4.1, so this tells me that this seems to be a bug introduced in the recent v8.5 update, so this is going to be something you’ll want to contact Realmac Software about directly.

Aside from this error displaying in the Master Styles page, are you having any other problem with Alloy? If you need to downgrade to RW v8.4.1 to use while you wait to hear back from Realmac Software you can get past versions of the app here on their Release Notes page: RapidWeaver Release Notes

I just ran a command line php. No rapidweaver.