Feedback on my first Foundry site?

Legvold Consulting

My first Foundry site, and about 3rd or 4th RW site.

There are still some things I want to do (anchor points to Navbar, f.x., better images, link to bio, add a blog, etc), but I think it looks ok to publish.

I’d appreciate any thoughts or suggestions to improve it!


This is looking really nice @Surf! Well done. I like the color palette you went with and the design and layout is nice and clean. Congrats!

Wow, thanks! That means a lot coming from you, with all your experience and professional background.

This time I actually sat down and made a “mini” style guide for the site before I even opened RapidWeaver, chose fonts and colors, and then worked from there. I think it made it easier to keep focus and deliver a clean result.

Clean and nice. Well done.:+1:

It definitely helps to plot things out ahead of time. I fall into the trap of not planning ahead like everyone else a lot of times when I build a site. I get too excited to just jump in and get started I guess. The extra work here shows in the results. Keep up the good work!

The site I made recently and showcased here broke, I’m not sure how.

I went into the project and added a few search tags in RW, didn’t change anything else, although I did upgrade plugins when prompted, and am now on RW8 instead of 7.

For some reason the translucent navbar across the top doesn’t display anymore, and at the bottom under Contact it says Foundry Control Center Stack is missing, but all the other info in the project displays correctly. I don’t see any stack named FCC, and I do have a Foundry stack at the top of the page with font and color definitions for the site. I thought that was the Foundry Control Center.

I am using Mega Menu nested in a Chroma stack, and use Chroma Markers with Solidnav to select sections on a continually scrolling page.

Could anyone give me a suggestion or two as to where to look to solve the problems?



There is an error on your page which seems to be causing the issue.

I’m not qualified to troubleshoot that in particular but, just to be sure that you cover your bases, have you tried to ‘Republish All Files’ just to be sure you have all your supporting files uploaded properly?

Hey there @Surf – can you do me a favor and try something out. I suspect something went amiss with a setting in your project. Try cycling this checkbox in the Mega Menu stack for me:


Then do a Republish All Files from the File Menu in RapidWeaver.

1 Like

Hi Jason,

that fixed it! Thank you so much! Maybe since it’s a new version of RW a few things have changed under the hood. I completely forgot that normal publishing only adds what’s changed, makes perfect sense that with a new version there might be underlying things that have far reaching consequences. Republished the whole site and now everything looks perfect! Wow!

What a great group pf people here. Thanks again for the help.



Thanks Adam,

I tried Jason’s suggestion first and it seemed to work. I’ve toggled the switch as recommended by you and republished once more, just to be sure.

Thanks for the great support!

1 Like

Glad to hear you got it all sorted. Likely just needed a Republish All Files then.

Hi guys,

new issue I just noticed. All stacks/plugins are up to date, I also tried the toggle mentioned in this thread and republished all files.

I see on my iPhone that the mobile site doesn’t show a hamburger for the menu, and all the check marks and other graphics are replaced by small boxes. Cute, but not what I want.

Any ideas where I can look to fix this? The desktop version looks and works perfectly.


Hey there @surf – Just took a look at your site on my iPhone here and everything is looking good as far as I can tell. I cleared my browser cache and then reloaded the page and it still looks A-OK. Below are some screenshots for you right from my iPhone.

Menu toggle icon seems to show fine:

Font icons for checkmarks look good too:

Images seem to be showing just fine too:

1 Like

Interesting. On my phone they’re small squares, on both Safari and Firefox Focus.
The only change I’ve made recently on my phone is to install a new DNS/VPN, Could that be affecting the images somehow?

Sounds like a possibility. Couldn’t hurt to try it without.

Tried pausing and disabling it. Same result, small boxes as placeholders. Maybe it’s just my phone, as long as it’s working elsewhere.

Have you tried clearing your browser cache and / or restarting the device?