Forbidden You don't have permission to access this resource


I’ve been using Alloy for a couple of months and everything’s been great until recently

All of a sudden, I can’t post, delete or correct posts in the Editor. I get an alert message saying: “Forbidden / You don’t have permission to access this resource.”

I’ve tried to reset my credentials but the problem remains. I can post a new blog article but I can’t modify or delete it, getting that bloody error message instead

What’s going on?

Thanks for your support


Those are not Alloy error messages. Those are messages relating to your server’s permissions for folders I believe. Have you or your host changed anything on your server recently? Alloy itself has not been updated recently so I suspect something with your server has changed.

To be honest, I would have preferred it to be Elixir’s bad: it would have been easier to fix

I’ll investigate on my server’s side then

Thanks a lot anyway for your reply. Alloy is a great tool. Well imagined, well concieved, well done. Keep rolling guys. You rock!



Sorry to get back to you, but my hosting provider has watched over the problem and tells me that the .htaccess file on my server is empty and shouldn’t be. I’ve not modified anything on that side, not knowing what to put in the .htaccess file and even less knowing how to modify it in order to make Alloy work properly.

Could you please tell me if there’s a permission to add and how to add it?

Hi @Anartiste

as your hosting provider guides you to look at the htaccess file, the only function of Alloy needing a htaccess change is “pretty urls”.

Can you please check if in Alloy under “Advanced” pretty url is checked?



I’ve checked it, followed the procedure as indicated in the page and updated the .htaccess file.

Now I can modify the blog articles, which is a great progression, but I still can’t delete them. The same error message appearing when I try to

Looks like we are probably on the right track :slight_smile:

Did you change the setting on all your Alloy pages? If you haven’t, then click on publish all pages.

I’ve updated both the Blog page and the Editor page, republished the entire site, but the problem remains the same: I can edit the articles and save them but still can’t delete them

Do you have access to your server via FTP?

If yes, create a new post lets say test123, save it. Then go via FTP to your Alloy blogs and try to delete your newly created post test123.

Do you receive also an error message?

When I process the deletion via FileZilla, everything goes fine: the post is deleted and disppears from the list in the editor

But when I try to delete the “This is an example blog post to get you started” post via the editor, I get the same error message

I‘m sorry, but I have no idea which helps any further.

Hi, could you Check the permissions on your .htaccess file, go on your server with filezilla and right-click on your .htaccess file. Normally you should see « in octal 0644 ». I don’t want to be scary but the change (regeneration without a voluntary action) of a .htaccess could indicate a compromission, did you notice other « changes » on your server ?

Hello Bruno,

Here’s the code I get when I open the .htaccess file on our server vie FileZilla :

RewriteEngine On

RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule news/(.*) blog/?id=$1 [L,NC,QSA]

No trace of the « in octal 0644 » line you mention. Should I add it to the file? If so, where should I put it?

No don’t do that, it’s not IN the file, it’s a property of the file, 0644 indicates that only the owner of the file can read and write the file, others can only read. You obtain this information by right-clicking on the name of the file : .htaccess with filezilla. What’ s in your file indicates the rules to name your blog files on the server. It’s ok. The thing we search is the permission to remove these files when you want within the Alloy blog editor. I don’t know if and/or how Alloy manage the permissions. It seems blog editor can write but not remove files after the application of the .htaccess rules. Maybe Adam could help when he’ll be back.

Ok. I looked at the .htaccess file on the server via FileZilla and found out about de permissions — you’ll find a copy enclosed

The code was 644. I typed 0644 but after saving the file, it returned to 644 so gusess it is normal…

Anyway, it didn’t change anything after my visite to the permissions: still unable to delete the post via Alloy interface ; have to do it manually

Ok the permissions on your htaccess file are good. It was important to check that because a htaccess don’t change by itself. So it’s a gateway for hackers. Now we are sure that’s ok. There is two possibilities for explaining your issue. First is the new setting of renaming blog files (htaccess was blank a while), second is a server restriction but I don’t think so. I can’t help more, sorry.

Check your posts folder permissions.

There it is…

Hi, ok this is good. Could you change permission of .htaccess file to 664 ? I think the problem occurs with permalinks. If it doesn’t change anything set it back to 644. Could you also check the permission of one post file for example ?