Foundry 2 SideNav not behaving as supposed

Hi everyone,

Would really appreciate a second, third, fourth pair of eyes on this one.

I have used Foundry 2’s sidenav on a number of websites, but all of a sudden on this particular site, it just is not working as it should.

This is a site where it is working properly:

This is the problem site:

I literally copied and pasted the 4x4toolbox one to the ashantiestate project.

The icons do not display when the side nave is contracted, and when it is extracted the alignment is not working.

I can send the project file via wetransfer as it is significant in size with all the resources.

Your help is much appreciated.

If it is working on one project and not the other, then there’s likely something different between the two. Copying and pasting from one project to another is often a nice quick way to get things done. But be sure you copy and pasted everything you need. Without seeing your project files it is hard to know what you’ve done in your projects. You can share those and perhaps someone can aid you in discovering your problem. I would backtrack though myself. Maybe even start anew and configure the nav again to see if the problem is the tool or the configuration / setup.

Hi @elixirgraphics Adam. I’ve done exactly as you suggested, but obviously I’m not seeing the mistake being made. I would really appreciate if someone could have a look at the project file. I’m sure my mistake will be easily spotted… Well, I hope, anyway. :grin: :face_with_peeking_eye:

How do I share the project file again? I can’t remember from last time. It’s over 500MB.

Wetransfer, Dropbox, etc. Make the file shareable, and post the link here.

Something with your Font Selection here is causing your issue.

I always recommend using Typeface as a beginning point. The custom option was deprecated and replaced with Typeface. I only left it in v2 as to not cause problems for legacy users.

Doublecheck that the font name is correct in Google Fonts after you re-setup things using Typeface instead. That said some Google Fonts are better made than others and the poorer ones can cause problems.

That said, it I set both to something like Arial it causes your problem to go away.


Wow! Ok, I don’t think I would’ve gotten to that solution. :exploding_head:
Thank you so much, Adam. As always your support is superb!

1 Like

Just have to start deleting and resetting things to the default sometimes to troubleshoot. I deleted everything from your page expect Side Nav and then added a brandnew Control Center. It worked, so I worked back forward from there adding items back to your page.

Thanks. Will keep that in mind next time I run into a problem like that.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.