Foundry Gallery Stack behaviour

I’ve set-up a 22 image photo gallery for my site.

I’m using the Foundry stack, with a Sections stack. The Foundry shipped Gallery is within one of the sections.

Having checked the site on mobile and desktop, I notice that the gallery behaves oddly.

When you scroll to or click on the gallery section, it shows the first image, then within 2 secs the page scrolls to the final row of images. Is this a setting I need to deselect somewhere? It means it is only possible to enter the individual images in the lightbox view by scrolling backwards and becomes frustrating pretty quickly.

The draft site is at if anyone has a chance to look. Please let me know what additional info you need.

Thanks in advance.

You have far too much content to fit within a single section. The Sections stack is trying to make it all fit. Sections is probably not appropriate for the type of page you’re designing there. You’ll want to use something more like the Mega Menu stack and its anchor navigation items. That would be a much better fit for that you’re trying to do, IMHO. Sections just isn’t built to handle a lot of content. Sections is for a content-lite site.


Hi Adam,
Thanks for taking a look.

Wow, I’m learning a lot. I had thought sorting the sections would do the job. I’ve bought Foundry, and the Potion Pack and still can’t do what I was aiming for.

The impression I got from reading up on Sections was that’s i could achieve it.

Now I’ve scanned the document info for Mega Menu, can I confirm that I would not use it with Foundry? So I’d drop Mega Menu into the blank stacks page in Rapidweaver?

The Mega Menu is part of the Potion Pack. Check out the tutorials and documentation page for it. You can still achieve the concept of what you want, but with more flexibility of the content on that page.

1 Like

Yes. The idea you have for a single page site can be accomplished with Foundry using the Mega Menu stack.

As an example I use it on my home page.


Thanks Steve, that’s handy.

Nice site!


I’ve now transfered my content onto a new project using Mega Menu (I’m using the Mega Menu provided by OneLittle Designer)

Does anyone have experience in linking the dropdown sections to the navigation menu? I’m a bit confused.

That would unfortunately not be the stack that @Steve_J was referring to. I’m not familiar with that stack or whether it allows anchor based navigation. The stack @Steve_J was talking about is the stack that comes as a part of the Potion Pack bundle for Foundry. You can find tutorials for my Mega Menu stack, as well as documentation, here: Potion Pack of Addons for Foundry

1 Like

Thank you for taking the time to reply and including the link, which I’ve made use of.

I have built a site based on the suggestions with the Mega Menu Foundry stack, with Anchors for the sections.

From what I can tell, the Anchor names are correctly labelled, and the anchor links work from the mega menu, however, I still can’t get my gallery to play nicely. The menu won’t skip to the Gallery section. I can scroll there, but not click through on the menu item.

Could it be that I’m overloading even this stack? I’ve gone through the gallery image by image and have tried to ensure that none of the image files are too massive.

The background image is large approx 1MB, but the rest of the images should all be pretty compact, below 500kb (largest at 468kb).

Any suggestions please?

Site is still at:

It will be much easier to help with your project file in-hand. You can send me a ZIP file containing your project file and I can take a look when I’m in the office next.

That’s really kind, thank you Adam.

I’ve tried a couple of ways in order to zip the file (originally 9.4MB), the smallest I can get it down to is 7.9MB and therefore it’s too big upload here.

If you’re comfortable going to this google drive link below, it is there. Sorry for the extra hassle!

Thanks in advance.

That will be fine. I wasn’t expecting an upload here, just an email, so this will be fine. I cannot look at it right now, but should be able to tomorrow (or possibly later today if holiday time permits).

Thank you. Whenever is convenient for you.

I unfortunately get this error each time I try to open your Zip file, and it refuses to uncompress.


Just got your DM with your project file.

Try renaming your anchor to something other then Gallery… try something like mygallery or something.

Also, just a side note, unrelated… use lowercase for stuff like anchors and links and such. Much lower chance of getting case sensitive stuff mixed up down the road.

You are a genius!

Thank you very much for such an easy fix!

No problem. Have a nice rest of the week.