Foundry header problem

I use the foundry header in the container. And it appeals like

"%[if edit]%

Foundry Control Center Stack Missing. Add the Control Panel to the page.


And I am using RepidWeaver version 7.5.2, Stacks 3, foundry 1.3

What seems to be the problem?

You need to add the Control Center stack to each page.

“Foundry has a main Control Center stack labeled “Foundry” that you will add to each of your pages. This main stack controls the basic, page-wide settings as well as provides the underlying CSS and javascript that will power each page. It offers a great deal of control for you in determining how your site will look and function. It is the fire in Foundry’s forge.”

Yes, the Control Center is added but does not work.
When I remove the Foundry version 1.3, and reinstall the version 1.2 from the the download link from the Email sent hours ago. It works.

Hi there @Ben_Yang

Can you send me a ZIP file containing a copy of your project file so that I may have a look at it here?

Foundry v1.3.0.0 was released October 12 of this year. It is odd that you’d just now get the update for it and it not come through sooner. Did you encounter any problems during updating to v1.3.0.0? Did RapidWeaver crash or anything during the update?

If you re-install v1.3.0.0 do you still have this problem?

Hi, after the update this time to 1.3, it is a problem no more.
Since I am new to Foundry, it is reasonable that I did not get the update on October 12 of this year.:grinning:
Thanks for you reply.
Your product is totally amazing.

Cool. Sounds like the update just didn’t get downloaded all of the way by Stacks. Glad it is working for you now.

Makes sense. Just wasn’t sure, so I thought I’d touch on that to figure out the deal.

THANKS! You’re too kind. Really appreciate it.

Going to go ahead and mark this one solved.

1 Like

Oh,no. It happened again when I tried the Pre-Built Projects downloaded from . My Mac OS is macOS High Sierra 10.13.1, and it is MacBook Pro(15-in, 2016).

Send me the requested file from my first post, above, and I can look at it when I am in the office next. Being a holiday weekend it may not be immediate, but I will have a look ASAP. (1.4 MB)
Don’t worry, I could still use the 1.2. Check this out when you are available

Hmmm, strange. I’m not getting that same problem here running v1.3.0.0. This is what I see:

I’m going to send you an email with the latest version of Foundry in case for some reason you’re having problems receiving the update fully.

Also, when you get a chance, let me know what version of RapidWeaver you’re using. You can find the version and build number here in the About window in RapidWeaver:

06 AM

Also, let me know what version of Stacks you’re using as well.

Well, my RW is 7.5.2.

About stacks, I just bought it one or two days ago in yourhead, it is version 3, but I find no place to have a look at exactly what it is. It is 3.5.5 and I found it in the Add-on manager:stacks version

I installed the version you sent me and I relaunched the RW 7. It is OK right now. I have no idea if it will be weird next time I open the same project.:joy:

OK. Let me know if you have further problems with it.

Same issue.
36 PM

When I check to update RW I get it’s the current version 7.5.2, even the download on the RW website is 7.5.2…
I’m using Foundry 1.3.042 PM

Maybe RW 7.5.2 could not download Foundry update completely?

I wonder if there is some issue with RW 7.5.2 and High Sierra (10.13.1).

I’m running RM 7.5.2, Stacks 3.0.0 and Foundry 1.3.0 on El Capitan (10.11.6) and have never seen this issue.

It sounds like 7.5.4 is due to be released this week. I know there were some issues with some version of RapidWeaver and High Sierra. Perhaps this will be fixed in it too.

The v7.5.4 download can be found here: 🐝 RapidWeaver 7.5.4 Beta - Announcements - RapidWeaver Support Forum

It is weird that this problem exists at all. I’ve yet to be able to replicate it. It appears almost as if Stacks is not processesing the conditional statements. I’m going to see if we can’t get @isaiah to have a look at this… @mmcd: Can you post a link to a ZIP file containing your project file that you’re experiencing this problem with, as well as to make sure to point out what page the problem is occurring on.

Anyone experiencing this problem, please also post the following, if you haven’t already… this way when @isaiah does get a chance to look at it, we’ll have a bit of information for him:

  • macOS Version Number
  • RapidWeaver Version Number
  • Stacks Version Number
  • Foundry Version Number

Might want to update your Stacks to 3.5.5

Couple of things to make sure of –

  • Be sure you’re running Stacks 3.5 or later. This is a requirement for Foundry. Always best to be using the latest version of Stacks.
  • If you have configured your addons folder to be anything other than the default in RapidWeaver, be sure it is still set to your alternate addons folder. Apparently I’m being told that sometimes this can revert to the default version after a macOS update. If it reverted to the default addons folder you may be using an older version of Stacks and not realize it.
1 Like

Good point. I am running Stacks 3.5.5. I had just looked at one of the included Stacks’ stacks and it’s 3.0.0. My bad.

I’m not having the issue and was just trying to point out that the only difference I saw was that Ben is running High Sierra. It looks like he is running Stacks 3.5.5.

I am OK with it now after I got the foundry update @elixirgraphics sent me by email :